summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2014-07-28 01:25:30 +0200
committerJens Geyer <jensg@apache.org>2014-11-09 01:58:25 +0100
commitbd52f1a1dd0a45aa01c551cdb15338ff3ac82a02 (patch)
tree290ffa559ff9f596ae3561e93bb899b81f5a5fda /configure.ac
parent4712f8c2e36fabfb00cfc67a6ecf5d6de20e3c18 (diff)
downloadthrift-bd52f1a1dd0a45aa01c551cdb15338ff3ac82a02.tar.gz
THRIFT-2644 Haxe support
Client: Haxe Patch: Jens Geyer This closes #214
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c49cb6039..9f104fa92 100755
--- a/configure.ac
+++ b/configure.ac
@@ -114,6 +114,7 @@ if test "$enable_libs" = "no"; then
with_python="no"
with_ruby="no"
with_haskell="no"
+ with_haxe="no"
with_perl="no"
with_php="no"
with_php_extension="no"
@@ -318,6 +319,16 @@ fi
AM_CONDITIONAL(WITH_GO, [test "$have_go" = "yes"])
+AX_THRIFT_LIB(haxe, [Haxe], yes)
+if test "$with_haxe" = "yes"; then
+ AC_PATH_PROG([HAXE], [haxe])
+ if [[ -x "$HAXE" ]] ; then
+ have_haxe="yes"
+ fi
+fi
+AM_CONDITIONAL(WITH_HAXE, [test "$have_haxe" = "yes"])
+
+
AX_THRIFT_LIB(d, [D], yes)
if test "$with_d" = "yes"; then
AX_DMD
@@ -657,6 +668,7 @@ AC_CONFIG_FILES([
test/cpp/Makefile
test/erl/Makefile
test/go/Makefile
+ test/haxe/Makefile
test/hs/Makefile
test/php/Makefile
test/perl/Makefile
@@ -668,6 +680,7 @@ AC_CONFIG_FILES([
tutorial/c_glib/Makefile
tutorial/cpp/Makefile
tutorial/go/Makefile
+ tutorial/haxe/Makefile
tutorial/hs/Makefile
tutorial/java/Makefile
tutorial/js/Makefile
@@ -690,6 +703,7 @@ echo "Building Java Library ........ : $have_java"
echo "Building C# Library .......... : $have_csharp"
echo "Building Python Library ...... : $have_python"
echo "Building Ruby Library ........ : $have_ruby"
+echo "Building Haxe Library ........ : $have_haxe"
echo "Building Haskell Library ..... : $have_haskell"
echo "Building Perl Library ........ : $have_perl"
echo "Building PHP Library ......... : $have_php"
@@ -739,6 +753,11 @@ if test "$have_haskell" = "yes" ; then
echo " Using Haskell ............. : $RUNHASKELL"
echo " Using Cabal ............... : $CABAL"
fi
+if test "$have_haxe" = "yes" ; then
+ echo
+ echo "Haxe Library:"
+ echo " Using Haxe ................ : $HAXE"
+fi
if test "$have_perl" = "yes" ; then
echo
echo "Perl Library:"