summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2015-07-28 23:12:10 +0200
committerJens Geyer <jensg@apache.org>2015-07-28 23:12:52 +0200
commit57ac33ea1a42e871ef03a7bda770a7ba16745ead (patch)
tree52e0ba568da8e4e8c83a9c91c43955d27ff38e62 /configure.ac
parent8c5fce9afabb2476c134a702356bb1bad1eb43f4 (diff)
downloadthrift-57ac33ea1a42e871ef03a7bda770a7ba16745ead.tar.gz
THRIFT-3264 Fix Erlang 16 namespaced types
Client: Erlang Patch: Nobuaki Sukegawa <nsukeg@gmail.com> This closes #566
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9af7f652e..0a3fd4396 100755
--- a/configure.ac
+++ b/configure.ac
@@ -231,9 +231,16 @@ if test "$with_erlang" = "yes"; then
fi
if test -n "$ERL" -a -n "$ERLC" ; then
have_erlang="yes"
+
+ # otp_release is simply a number (like "17") for OTP17+ while "R16..." for OTP16 or less.
+ # OTP version is currently only used for running tests.
+ if $ERL -eval 'erlang:display(erlang:system_info(otp_release)),halt().' -noshell | grep "^\"R" >/dev/null; then
+ erlang_otp16_or_less="yes"
+ fi
fi
fi
AM_CONDITIONAL(WITH_ERLANG, [test "$have_erlang" = "yes"])
+AM_CONDITIONAL(ERLANG_OTP16, [test "$erlang_otp16_or_less" = "yes"])
AX_THRIFT_LIB(nodejs, [Nodejs], yes)
have_nodejs=no