summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2015-03-18 23:38:43 +0200
committerJens Geyer <jensg@apache.org>2015-03-19 04:08:18 +0200
commit0cfdf7cb9de0657f01882e356f447651914e4a21 (patch)
treefeadd4332e5664d7edcd263ed96b9344c843172b /configure.ac
parentd565e2f496ab894e737b143cf71c2f5e3cee871b (diff)
downloadthrift-0cfdf7cb9de0657f01882e356f447651914e4a21.tar.gz
THRIFT-2598 Add check for minimum Go version to configure.ac
Client: Go Patch: Jens Geyer This closes #399
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 333a4e5d4..6b26de571 100755
--- a/configure.ac
+++ b/configure.ac
@@ -340,7 +340,24 @@ AX_THRIFT_LIB(go, [Go], yes)
if test "$with_go" = "yes"; then
AC_PATH_PROG([GO], [go])
if [[ -x "$GO" ]] ; then
- have_go="yes"
+ AS_IF([test -n "$GO"],[
+ ax_go_version="1.4"
+
+ AC_MSG_CHECKING([for Go version])
+ golang_version=`$GO version 2>&1 | $SED -e 's/\(go \)\(version \)\(go\)\(@<:@0-9@:>@.@<:@0-9@:>@.@<:@0-9@:>@\)\(@<:@\*@:>@*\).*/\4/'`
+ AC_MSG_RESULT($golang_version)
+ AC_SUBST([golang_version],[$golang_version])
+ AX_COMPARE_VERSION([$ax_go_version],[le],[$golang_version],[
+ :
+ have_go="yes"
+ ],[
+ :
+ have_go="no"
+ ])
+ ],[
+ AC_MSG_WARN([could not find Go ])
+ have_go="no"
+ ])
fi
fi
AM_CONDITIONAL(WITH_GO, [test "$have_go" = "yes"])