summaryrefslogtreecommitdiff
path: root/compiler/cpp/Makefile.am
diff options
context:
space:
mode:
authorChris Piro <cpiro@apache.org>2013-03-07 11:24:51 -0500
committerChris Piro <cpiro@apache.org>2013-03-07 11:24:51 -0500
commit92e3860cfbaab5132439b9bac2e18dba06494bcc (patch)
tree5bffdf5ab615a53489b675078aa08754801a5afb /compiler/cpp/Makefile.am
parent073f9eb9b920bda948b306ee16e78743e42b7cd1 (diff)
downloadthrift-92e3860cfbaab5132439b9bac2e18dba06494bcc.tar.gz
THRIFT-1614: handle automake >= 1.12 yacc output name (thrifty.hh)
Diffstat (limited to 'compiler/cpp/Makefile.am')
-rw-r--r--compiler/cpp/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/compiler/cpp/Makefile.am b/compiler/cpp/Makefile.am
index f47b15f05..8a8f394ae 100644
--- a/compiler/cpp/Makefile.am
+++ b/compiler/cpp/Makefile.am
@@ -106,6 +106,7 @@ EXTRA_DIST = \
$(WINDOWS_DIST)
clean-local:
- $(RM) thriftl.cc thrifty.cc thrifty.h version.h windows/version.h
+ $(RM) thriftl.cc thrifty.cc thrifty.h thrifty.hh version.h windows/version.h
+ echo '#include "thrifty.h"' > compiler/cpp/thrifty.hh
src/main.cc: version.h