summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2007-03-18 04:51:52 +0000
committerBob Ippolito <bob@redivi.com>2007-03-18 04:51:52 +0000
commita0fac116e1e5fd038174312c5b52d15a163fcbc8 (patch)
tree615dcd6d0ab1843cc18507ed731eb00f2a12a13e /setup.py
parentbe103d0368413157c2ac4df0c8b67e97f735bc34 (diff)
downloadsimplejson-a0fac116e1e5fd038174312c5b52d15a163fcbc8.tar.gz
optional C speedups
git-svn-id: http://simplejson.googlecode.com/svn/trunk@45 a4795897-2c25-0410-b006-0d3caba88fa1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 13 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 7cf6d49..4a8d7b5 100644
--- a/setup.py
+++ b/setup.py
@@ -3,14 +3,15 @@
import ez_setup
ez_setup.use_setuptools()
-from setuptools import setup, find_packages
+from setuptools import setup, find_packages, Extension, Feature
-VERSION = '1.6'
+VERSION = '1.7'
DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python"
LONG_DESCRIPTION = """
simplejson is a simple, fast, complete, correct and extensible
JSON <http://json.org> encoder and decoder for Python 2.3+. It is
-pure Python code with no dependencies.
+pure Python code with no dependencies, but includes an optional C
+extension for a serious speed boost.
simplejson was formerly known as simple_json, but changed its name to
comply with PEP 8 module naming guidelines.
@@ -31,6 +32,14 @@ Programming Language :: Python
Topic :: Software Development :: Libraries :: Python Modules
""".splitlines()))
+speedups = Feature(
+ "options C speed-enhancement modules",
+ standard=True,
+ ext_modules = [
+ Extension("simplejson._speedups", ["simplejson/_speedups.c"]),
+ ],
+)
+
setup(
name="simplejson",
version=VERSION,
@@ -48,4 +57,5 @@ setup(
entry_points={
'paste.filter_app_factory': ['json = simplejson.jsonfilter:factory'],
},
+ features={'speedups': speedups},
)