summaryrefslogtreecommitdiff
path: root/src/webchannel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/webchannel/CMakeLists.txt')
-rw-r--r--src/webchannel/CMakeLists.txt64
1 files changed, 64 insertions, 0 deletions
diff --git a/src/webchannel/CMakeLists.txt b/src/webchannel/CMakeLists.txt
new file mode 100644
index 0000000..4f7f940
--- /dev/null
+++ b/src/webchannel/CMakeLists.txt
@@ -0,0 +1,64 @@
+# Generated from webchannel.pro.
+
+#####################################################################
+## WebChannel Module:
+#####################################################################
+
+add_qt_module(WebChannel
+ SOURCES
+ qmetaobjectpublisher.cpp qmetaobjectpublisher_p.h
+ qwebchannel.cpp qwebchannel.h qwebchannel_p.h
+ qwebchannelabstracttransport.cpp qwebchannelabstracttransport.h
+ signalhandler_p.h
+ variantargument_p.h
+ LIBRARIES
+ Qt::CorePrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+)
+
+# Resources:
+set_source_files_properties("../../examples/webchannel/shared/qwebchannel.js"
+ PROPERTIES QT_RESOURCE_ALIAS "qwebchannel.js"
+)
+set(resources_resource_files
+ "../../examples/webchannel/shared/qwebchannel.js"
+)
+
+set_source_files_properties(${resources_resource_files} PROPERTIES QT_SKIP_QUICKCOMPILER 1)
+
+add_qt_resource(WebChannel "resources"
+ PREFIX
+ "/qtwebchannel/"
+ FILES
+ ${resources_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:webchannel.pro:<TRUE>:
+# OTHER_FILES = "qwebchannel.js"
+# _LOADED = "qt_module"
+
+## Scopes:
+#####################################################################
+
+extend_target(WebChannel CONDITION TARGET Qt::Qml
+ SOURCES
+ qqmlwebchannel.cpp
+ qqmlwebchannelattached.cpp
+ PUBLIC_LIBRARIES
+ Qt::Qml
+)
+
+#### Keys ignored in scope 2:.:.:webchannel.pro:TARGET Qt::Qml:
+# PRIVATE_HEADERS = "qqmlwebchannelattached_p.h"
+# PUBLIC_HEADERS = "qqmlwebchannel.h"
+
+extend_target(WebChannel CONDITION NOT TARGET Qt::Qml
+ DEFINES
+ QT_NO_JSVALUE
+)
+add_qt_docs(
+ doc/qtwebchannel.qdocconf
+)
+