summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad989ba838..b13365b274 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1051,3 +1051,9 @@ add_subdirectory(${PROJECT_SOURCE_DIR}/render-test)
if(EXISTS ${PROJECT_SOURCE_DIR}/internal/internal.cmake)
include(${PROJECT_SOURCE_DIR}/internal/internal.cmake)
endif()
+
+# installs
+include(GNUInstallDirs)
+install(DIRECTORY include/mbgl
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
+ COMPONENT development)