summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Firebaugh <john.firebaugh@gmail.com>2017-02-15 11:25:47 -0800
committerJohn Firebaugh <john.firebaugh@gmail.com>2017-02-15 15:09:30 -0600
commiteb8a1ef7aa43582202c8b385b9ee0665cc6c838c (patch)
treec9c9bc6acb8db5b9e9b9d4146b74ebe4f6e3827d /CMakeLists.txt
parent0c0d7ceaebf822ababc7147c494e88f4c16e18e3 (diff)
downloadqtlocation-mapboxgl-eb8a1ef7aa43582202c8b385b9ee0665cc6c838c.tar.gz
[tests] Disable timing-based Timer tests in CI
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 56c1fc684d..90f5bf7e1c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,6 @@ option(WITH_CXX11ABI "Use cxx11abi mason packages" OFF)
option(WITH_COVERAGE "Enable coverage reports" OFF)
option(WITH_OSMESA "Use OSMesa headless backend" OFF)
option(WITH_EGL "Use EGL backend" OFF)
-option(IS_CI_BUILD "Continuous integration build" OFF)
if(WITH_CXX11ABI)
set(MASON_CXXABI_SUFFIX -cxx11abi)
@@ -23,7 +22,7 @@ if(WITH_EGL)
add_definitions(-DMBGL_USE_GLES2=1)
endif()
-if(IS_CI_BUILD)
+if($ENV{CI})
add_compile_options(-DCI_BUILD=1)
endif()