summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Käfer <mail@kkaefer.com>2017-01-18 11:57:27 +0100
committerKonstantin Käfer <mail@kkaefer.com>2017-01-19 10:50:07 +0100
commitdbd7186bc55e801e4541b5d3ecb9181224ea667c (patch)
tree2546e8e1bd33a9f383b572da06fe253df6225af8 /CMakeLists.txt
parenta2ceeb4a5b7a8db4bbd852c5e51085d9220a5c3d (diff)
downloadqtlocation-mapboxgl-dbd7186bc55e801e4541b5d3ecb9181224ea667c.tar.gz
[build] Run submodule update on every build, and npm install when the package.json changed
We're now running a submodule update as part of every build, and when the project files are generated. We also run an npm install whenever the package.json was updated, both during project generation and as part of every build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59d84d33fc..92b0715b5e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,27 +3,6 @@ project(mbgl LANGUAGES CXX C)
set(CMAKE_CXX_STANDARD 14)
include(cmake/mbgl.cmake)
-
-if(NOT EXISTS ".mason/mason.cmake")
- execute_process(
- COMMAND git submodule update --init .mason
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
-endif()
-
-if(NOT EXISTS "mapbox-gl-js/package.json")
- execute_process(
- COMMAND git submodule update --init mapbox-gl-js
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
- # Symlink mapbox-gl-js/node_modules so that the modules that are
- # about to be installed get cached between CI runs.
- execute_process(
- COMMAND ln -sF ../node_modules .
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/mapbox-gl-js)
- execute_process(
- COMMAND npm install
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/mapbox-gl-js)
-endif()
-
include(.mason/mason.cmake)
option(WITH_CXX11ABI "Use cxx11abi mason packages" OFF)