summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Loer <chris.loer@gmail.com>2016-11-17 14:12:28 -0800
committerJohn Firebaugh <john.firebaugh@gmail.com>2016-11-17 14:33:03 -0800
commitbceeba29a3fa85105c21718ed0be8704508ab585 (patch)
tree1fd7bba911a0c407d656ca53257631b5ec0bfea1 /CMakeLists.txt
parent40b0c8d0760f8a767ef4646607ac63251d86de8d (diff)
downloadqtlocation-mapboxgl-bceeba29a3fa85105c21718ed0be8704508ab585.tar.gz
[core] Add ICU package for Bidirectional text support and arabic text shaping.
Apply bidi and shaping in symbol_layout. Add utility functions for converting to and from UTF-16.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 064710780f..6358976e6a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,6 +52,7 @@ mason_use(earcut VERSION 0.12.1 HEADER_ONLY)
mason_use(protozero VERSION 1.4.2 HEADER_ONLY)
mason_use(pixelmatch VERSION 0.10.0 HEADER_ONLY)
mason_use(geojson VERSION 0.3.2 HEADER_ONLY)
+mason_use(icu VERSION 58.1)
if(WITH_COVERAGE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --coverage")