summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBruno de Oliveira Abinader <bruno@mapbox.com>2016-10-24 19:03:55 +0300
committerBruno de Oliveira Abinader <bruno@mapbox.com>2016-10-24 21:38:12 +0300
commit89ba2f21519a282f3633f605932335c98bf34590 (patch)
treeb4038a6e57953e57d6a0357f04781b27f7b53e14 /CMakeLists.txt
parentcff5360280c763b76ef70e42a2d66a1a755bcb35 (diff)
downloadqtlocation-mapboxgl-89ba2f21519a282f3633f605932335c98bf34590.tar.gz
[build] Set C++14 as default standard for CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d021c856fb..9169dea812 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,6 @@
cmake_minimum_required(VERSION 3.1)
project(mbgl LANGUAGES CXX C)
+set(CMAKE_CXX_STANDARD 14)
include(cmake/mbgl.cmake)
@@ -44,6 +45,11 @@ if(APPLE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=unused-command-line-argument")
endif()
+if(CMAKE_COMPILER_IS_GNUCXX)
+ # https://svn.boost.org/trac/boost/ticket/9240
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fext-numeric-literals")
+endif()
+
if(NOT EXISTS ${CMAKE_SOURCE_DIR}/platform/${MBGL_PLATFORM}/config.cmake)
message(ERROR "Can't find config.cmake file for platform ${MBGL_PLATFORM}")
endif()