summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Firebaugh <john.firebaugh@gmail.com>2017-03-01 21:52:38 -0800
committerJohn Firebaugh <john.firebaugh@gmail.com>2017-03-02 16:32:42 -0800
commit8742dc852c82ef40003a22a8e0a764616d8beed1 (patch)
treeef1eec3b9e985129e26e90eb9c19624358b080a0 /CMakeLists.txt
parent8a5cc3560ac3ed5b2aa6273c7fbbd92a3692b1ec (diff)
downloadqtlocation-mapboxgl-8742dc852c82ef40003a22a8e0a764616d8beed1.tar.gz
[all] Build all release builds with -Os
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90f5bf7e1c..123158e2eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,6 +66,7 @@ if(APPLE)
# -Wno-error=unused-command-line-argument is required due to https://llvm.org/bugs/show_bug.cgi?id=7798
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=unused-command-line-argument")
endif()
+set(CMAKE_CXX_FLAGS_RELEASE "-Os -DNDEBUG")
if(CMAKE_COMPILER_IS_GNUCXX)
# https://svn.boost.org/trac/boost/ticket/9240