summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBruno de Oliveira Abinader <bruno@mapbox.com>2017-04-27 18:00:30 +0300
committerBruno de Oliveira Abinader <bruno@mapbox.com>2017-04-27 18:45:56 +0300
commit52cddfc08addf17e23f9cf74787a6ead40797c1d (patch)
treeea7c3ae4d017221be129c8643a07d78be5ebd862 /CMakeLists.txt
parent9be076ffe9021bbd83b195e6f69d17c366fbf79f (diff)
downloadqtlocation-mapboxgl-52cddfc08addf17e23f9cf74787a6ead40797c1d.tar.gz
[build] Control libstdc++ usage via WITH_CXX11ABI
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e7ee314e7..f8757d0c88 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,9 @@ option(WITH_EGL "Use EGL backend" OFF)
if(WITH_CXX11ABI)
set(MASON_CXXABI_SUFFIX -cxx11abi)
+ add_definitions(-D_GLIBCXX_USE_CXX11_ABI=1)
+else()
+ add_definitions(-D_GLIBCXX_USE_CXX11_ABI=0)
endif()
if(WITH_OSMESA AND WITH_EGL)