summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Firebaugh <john.firebaugh@gmail.com>2017-01-19 13:13:06 -0800
committerJohn Firebaugh <john.firebaugh@gmail.com>2017-01-23 11:13:42 -0600
commit0ccc255f0e097b823537c37495b39de554f600fb (patch)
tree0d68fb62f3255415af383cbf05871aae91b38069 /CMakeLists.txt
parentea36c519689ddd327cb70311d484af593bc8883f (diff)
downloadqtlocation-mapboxgl-0ccc255f0e097b823537c37495b39de554f600fb.tar.gz
[linux] mesa 13.0.3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92b0715b5e..6265c05069 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,14 +19,8 @@ if(WITH_OSMESA AND WITH_EGL)
message(FATAL_ERROR "WITH_OSMESA and WITH_EGL are mutually exclusive.")
endif()
-if(WITH_OSMESA)
- # Default mesa mason binary is OSMesa.
- set(MASON_MESA_SUFFIX "")
-elseif(WITH_EGL)
+if(WITH_EGL)
add_definitions(-DMBGL_USE_GLES2=1)
- set(MASON_MESA_SUFFIX "-egl")
-else()
- set(MASON_MESA_SUFFIX "-glx")
endif()
if(IS_CI_BUILD)