summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Firebaugh <john.firebaugh@gmail.com>2016-12-19 17:10:51 -0800
committerJohn Firebaugh <john.firebaugh@gmail.com>2017-01-04 17:38:33 -0800
commit0c0064c050396eae8dad92e5097692537405704a (patch)
tree5eb3c975fc4295b7fcbc244258f8facbc1f7e30a /CMakeLists.txt
parent59803d3025683a255737b5ae29bd7fc531a975a3 (diff)
downloadqtlocation-mapboxgl-0c0064c050396eae8dad92e5097692537405704a.tar.gz
[core] Get rid of user-specified refs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9f52ba9de..41df0f2a12 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,6 +60,8 @@ mason_use(pixelmatch VERSION 0.10.0 HEADER_ONLY)
mason_use(geojson VERSION 0.4.0 HEADER_ONLY)
mason_use(polylabel VERSION 1.0.2 HEADER_ONLY)
+add_definitions(-DRAPIDJSON_HAS_STDSTRING=1)
+
if(WITH_COVERAGE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --coverage")
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} --coverage")