summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpje <pje@571e12c6-e1fa-0310-aee7-ff1267fa46bd>2004-10-05 20:13:57 +0000
committerpje <pje@571e12c6-e1fa-0310-aee7-ff1267fa46bd>2004-10-05 20:13:57 +0000
commit40e4df69ce749b147cb944294d89b9b9ed466a6c (patch)
tree232de10eebc01349483b2113b4d77a5d711a82e7
parent28be66133d8dd95ddb28800b8e50b16f56b084fc (diff)
downloadwsgiref-40e4df69ce749b147cb944294d89b9b9ed466a6c.tar.gz
Created initial "setup and test" shell for 'wsgiref' library.
git-svn-id: svn://svn.eby-sarna.com/svnroot/wsgiref@246 571e12c6-e1fa-0310-aee7-ff1267fa46bd
-rwxr-xr-xsetup.py26
-rw-r--r--src/wsgiref/__init__.py18
-rw-r--r--src/wsgiref/tests/__init__.py18
3 files changed, 62 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..6cb4206
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+#!/usr/bin/env python
+
+"""Distutils setup file"""
+
+from setuptools import setup, find_packages
+
+# Metadata
+PACKAGE_NAME = "wsgiref"
+PACKAGE_VERSION = "0.0.1"
+
+setup(
+ name=PACKAGE_NAME,
+ version=PACKAGE_VERSION,
+
+ description="WSGI (PEP 333) Reference Library",
+ author="Phillip J. Eby",
+ author_email="peak@eby-sarna.com",
+ license="PSF or ZPL",
+
+ url="http://www.python.org/peps/pep-0333.html",
+
+ test_suite = 'wsgiref.tests.test_suite',
+ package_dir = {'':'src'},
+ packages = find_packages('src'),
+)
+
diff --git a/src/wsgiref/__init__.py b/src/wsgiref/__init__.py
new file mode 100644
index 0000000..d130a83
--- /dev/null
+++ b/src/wsgiref/__init__.py
@@ -0,0 +1,18 @@
+"""wsgiref -- a WSGI (PEP 333) Reference Library
+
+Contained Modules:
+
+ * util -- Miscellaneous useful functions and wrappers
+
+ * headers -- Manage response headers
+
+ * handler -- base classes for server/gateway implementations
+
+ * server -- a SimpleHTTPServer that supports WSGI
+
+ * cgi_gateway -- Run WSGI apps under CGI
+
+ * cgi_wrapper -- Run CGI apps under WSGI
+
+ * router -- a simple middleware component that handles URL traversal
+"""
diff --git a/src/wsgiref/tests/__init__.py b/src/wsgiref/tests/__init__.py
new file mode 100644
index 0000000..8ada027
--- /dev/null
+++ b/src/wsgiref/tests/__init__.py
@@ -0,0 +1,18 @@
+from unittest import TestSuite, TestCase, makeSuite
+
+def test_suite():
+
+ #from wsgiref.tests import test_xyz
+
+ tests = [
+ #test_xyz.test_suite(),
+ ]
+
+ return TestSuite(tests)
+
+
+
+
+
+
+