summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Ward <ian@excess.org>2013-12-27 10:05:03 -0500
committerIan Ward <ian@excess.org>2013-12-27 10:05:03 -0500
commit5482dae93483a757224d2ab913517b31085878de (patch)
tree8aeae2ca0a8c7f714b354f5c872c901a4bc83275
parent56095c609aa1c699b6701caec4b5057b362782ca (diff)
downloadurwid-5482dae93483a757224d2ab913517b31085878de.tar.gz
travis: show optional deps
-rw-r--r--.travis.yml2
-rwxr-xr-xbin/deps.py25
2 files changed, 27 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
index a4136a2..d9c0a8d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -11,4 +11,6 @@ before_install:
- "sudo apt-get install python-gi python3-gi"
install:
- "pip install --use-mirrors setuptools twisted tornado"
+ - "DEPS=`python bin/deps.py`"
+ - "echo $TRAVIS_PYTHON_VERSION $DEPS"
script: python setup.py test
diff --git a/bin/deps.py b/bin/deps.py
new file mode 100755
index 0000000..01489d6
--- /dev/null
+++ b/bin/deps.py
@@ -0,0 +1,25 @@
+#!/usr/bin/env python
+"""
+show optional Urwid dependencies installed
+"""
+deps = []
+
+try:
+ import gi.repository
+ deps.append("pygobject")
+except ImportError:
+ pass
+
+try:
+ import tornado
+ deps.append("tornado")
+except ImportError:
+ pass
+
+try:
+ import twisted
+ deps.append("twisted")
+except ImportError:
+ pass
+
+print(" ".join(deps))