summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2014-09-02 14:55:16 +0200
committerholger krekel <holger@merlinux.eu>2014-09-02 14:55:16 +0200
commitbf52a34ed710df36143bc006fa7750f35550ef9e (patch)
tree710e153a8581726a23be87e286d95785feccee73
parent45a0a8507d53fe85c748dbbed8b940ea2ee2d4dd (diff)
downloadtox-bf52a34ed710df36143bc006fa7750f35550ef9e.tar.gz
fix issue148: ignore __PYVENV_LAUNCHER__ for subproc
-rw-r--r--CHANGELOG3
-rw-r--r--doc/Makefile2
-rw-r--r--doc/conf.py3
-rw-r--r--setup.py2
-rw-r--r--tests/test_venv.py2
-rw-r--r--tox/__init__.py2
6 files changed, 10 insertions, 4 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 9d991c7..4597560 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -4,6 +4,9 @@
- new multi-dimensional configuration support. Many thanks to
Alexander Schepanovski for the complete PR with docs.
+- fix issue148: remove "__PYVENV_LAUNCHER__" from os.environ when starting
+ subprocesses. Thanks Seven Myint.
+
1.7.2
-----------
diff --git a/doc/Makefile b/doc/Makefile
index 77b2083..d3393d6 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -37,7 +37,7 @@ clean:
-rm -rf $(BUILDDIR)/*
install: clean html
- @rsync -avz $(BUILDDIR)/html/ testrun.org:/www/testrun.org/tox/latest
+ @rsync -avz $(BUILDDIR)/html/ testrun.org:/www/testrun.org/tox/dev
#latexpdf
#@scp $(BUILDDIR)/latex/*.pdf testrun.org:www-tox/latest
diff --git a/doc/conf.py b/doc/conf.py
index ceb3397..0221f3c 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -48,7 +48,8 @@ copyright = u'2013, holger krekel and others'
# built documents.
#
# The short X.Y version.
-release = version = "1.7.2"
+release = "1.8"
+version = "1.8.0.dev"
# The full version, including alpha/beta/rc tags.
# The language for content autogenerated by Sphinx. Refer to documentation
diff --git a/setup.py b/setup.py
index 8e2f8f0..f8390bb 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='1.7.2',
+ version='1.8.0.dev1',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tests/test_venv.py b/tests/test_venv.py
index f6a2f32..00e5f8b 100644
--- a/tests/test_venv.py
+++ b/tests/test_venv.py
@@ -485,9 +485,11 @@ class TestVenvTest:
py.test.raises(ZeroDivisionError, "venv._pcall([1,2,3])")
monkeypatch.setenv("PIP_RESPECT_VIRTUALENV", "1")
monkeypatch.setenv("PIP_REQUIRE_VIRTUALENV", "1")
+ monkeypatch.setenv("__PYVENV_LAUNCHER__", "1")
py.test.raises(ZeroDivisionError, "venv.run_install_command(['qwe'])")
assert 'PIP_RESPECT_VIRTUALENV' not in os.environ
assert 'PIP_REQUIRE_VIRTUALENV' not in os.environ
+ assert '__PYVENV_LAUNCHER__' not in os.environ
def test_setenv_added_to_pcall(tmpdir, mocksession, newconfig):
pkg = tmpdir.ensure("package.tar.gz")
diff --git a/tox/__init__.py b/tox/__init__.py
index 530f3c4..e12f703 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.7.2'
+__version__ = '1.8.0.dev1'
class exception:
class Error(Exception):