summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorianb <devnull@localhost>2007-07-23 23:09:44 +0000
committerianb <devnull@localhost>2007-07-23 23:09:44 +0000
commit7d88f864254495cbd8a589b7847a1be9d2db3c9b (patch)
treec8541d0f34263fac1dbd48392c640d03e4dc2801
parent19242c5862a81cea3f6a8ae2c9bc7623c408a917 (diff)
downloadtempita-7d88f864254495cbd8a589b7847a1be9d2db3c9b.tar.gz
Initial layout
-rw-r--r--docs/index.txt15
-rw-r--r--docs/license.txt20
-rw-r--r--setup.cfg34
-rw-r--r--setup.py29
-rw-r--r--tempita/__init__.py1
5 files changed, 99 insertions, 0 deletions
diff --git a/docs/index.txt b/docs/index.txt
new file mode 100644
index 0000000..def94a8
--- /dev/null
+++ b/docs/index.txt
@@ -0,0 +1,15 @@
+Tempita
++++++++
+
+:author: Ian Bicking <ianb@colorstudy.com>
+
+Status & License
+================
+
+Tempita is available under an `MIT-style license <license.html>`_.
+
+It is actively developed, but not an ambitious project. It does not
+seek to take over the templating world, or adopt many new features.
+I just wanted a small templating language for cases when ``%`` and
+``string.Template`` weren't enough.
+
diff --git a/docs/license.txt b/docs/license.txt
new file mode 100644
index 0000000..2e4ecaa
--- /dev/null
+++ b/docs/license.txt
@@ -0,0 +1,20 @@
+Copyright (c) 2007 Ian Bicking and Contributors
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
+LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..5d371d4
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,34 @@
+[global]
+command_packages = buildutils.pudge_command, buildutils.publish_command
+
+[egg_info]
+tag_build = dev
+tag_svn_revision = true
+
+[pudge]
+organization = Python Paste
+highlighter = pygments
+settings = no_about=true
+ link1=http://cheeseshop.python.org/pypi/Tempita Download
+ extra_credits=Hosting courtesy of <a href="http://tummy.com">Tummy.com</a>
+dest = docs/html
+docs = docs/index.txt docs/license.txt
+title = Tempita
+modules = tempita
+doc_base = docs/
+theme = pythonpaste.org
+mailing_list_url = /community/mailing-list.html
+organization_url = http://pythonpaste.org/
+trac_url = http://trac.pythonpaste.org/
+
+[publish]
+doc-dest = scp://ianb@webwareforpython.org/home/paste/htdocs/tempita
+make-dirs = 1
+doc-dir = docs/html
+
+[aliases]
+distribute = register sdist bdist_egg upload pudge publish
+
+[egg_info]
+tag_build = dev
+tag_svn_revision = true
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..078b167
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+from setuptools import setup, find_packages
+import sys, os
+
+version = '0.1'
+
+setup(name='Tempita',
+ version=version,
+ description="A very small text templating language",
+ long_description="""\
+""",
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Topic :: Text Processing',
+ ],
+ keywords='templating template language html',
+ author='Ian Bicking',
+ author_email='ianb@colorstudy.com',
+ url='',
+ license='MIT',
+ packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+ include_package_data=True,
+ zip_safe=True,
+ install_requires=[
+ ],
+ entry_points="""
+ """,
+ )
diff --git a/tempita/__init__.py b/tempita/__init__.py
new file mode 100644
index 0000000..792d600
--- /dev/null
+++ b/tempita/__init__.py
@@ -0,0 +1 @@
+#