summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjortel <devnull@localhost>2008-11-11 17:43:40 +0000
committerjortel <devnull@localhost>2008-11-11 17:43:40 +0000
commitbadd30a87f676d632d7386b05401e6029a5df83c (patch)
tree66eaebeb24c95aab2027833951edae73d4fcd667
parent50f24f63c37e2e8feb797fc1bbcb55499cad7173 (diff)
downloadsuds-badd30a87f676d632d7386b05401e6029a5df83c.tar.gz
GA release: bump version and reset release to (1).release-0.3.2
-rw-r--r--README2
-rw-r--r--python-suds.spec2
-rw-r--r--suds/__init__.py2
-rw-r--r--tests/public.py49
4 files changed, 26 insertions, 29 deletions
diff --git a/README b/README
index 951c58f..8912b2f 100644
--- a/README
+++ b/README
@@ -1200,4 +1200,4 @@ version 0.3.2 (11-7-08):
* setlocation() - Override the location in the wsdl; same as keyword except for all calls.
* setproxy() - same as proxy keyword but for all invocations.
* Add proper namespace prefix for soap headers.
- * Fixed Tickets: #5, #12, #34, #37, #40, #44, #45, #46, #48, #49, #50 \ No newline at end of file
+ * Fixed Tickets: #5, #12, #34, #37, #40, #44, #45, #46, #48, #49, #50, #51 \ No newline at end of file
diff --git a/python-suds.spec b/python-suds.spec
index 23b1093..1fbef5a 100644
--- a/python-suds.spec
+++ b/python-suds.spec
@@ -79,7 +79,7 @@ rm -rf $RPM_BUILD_ROOT
setlocation() - Override the location in the wsdl.
setproxy() - Same as proxy keyword but for all invocations.
- Add proper namespace prefix for soap headers.
-- Fixed Tickets: #5, #12, #34, #37, #40, #44, #45, #46, #48, #49, #50
+- Fixed Tickets: #5, #12, #34, #37, #40, #44, #45, #46, #48, #49, #50, #51
* Fri Nov 03 2008 jortel <jortel@redhat.com> - 0.3.1-5
- Add LICENSE to %%doc.
diff --git a/suds/__init__.py b/suds/__init__.py
index f9f2b44..71b562b 100644
--- a/suds/__init__.py
+++ b/suds/__init__.py
@@ -29,7 +29,7 @@ import socket
# Project properties
#
-properties = dict(version='0.3.2', build="beta R385-20081110")
+properties = dict(version='0.3.2', build="R386-20081111")
#
# Exceptions
diff --git a/tests/public.py b/tests/public.py
index 4b67dc2..0415d58 100644
--- a/tests/public.py
+++ b/tests/public.py
@@ -35,20 +35,32 @@ Import.bind('http://schemas.xmlsoap.org/soap/encoding/')
#logging.getLogger('suds.metrics').setLevel(logging.DEBUG)
#logging.getLogger('suds').setLevel(logging.DEBUG)
+
def start(url):
global errors
print '\n________________________________________________________________\n'
print 'Test @ ( %s ) %d' % (url, errors)
-
+
try:
- url = 'http://jira.atlassian.com/rpc/soap/jirasoapservice-v2?wsdl'
+ url = 'http://mssoapinterop.org/asmx/simple.asmx?WSDL'
start(url)
client = Client(url)
print client
- token = client.service.login('soaptester', 'soaptester')
- print 'token="%s"' % token
- user = client.service.getUser(token, 'soaptester')
- print 'user="%s"' % token
+ # string
+ input = "42"
+ result = client.service.echoString(input)
+ print 'echoString() = %s' % result
+ assert result == input
+ # int
+ input = 42
+ result = client.service.echoInteger(input)
+ print 'echoInteger() = %s' % result
+ assert result == input
+ # float
+ input = 4.2
+ result = client.service.echoFloat(input)
+ print 'echoFloat() = %s' % result
+ assert result == input
except WebFault, f:
errors += 1
print f
@@ -59,11 +71,14 @@ except Exception, e:
tb.print_exc()
try:
- url = ' http://www.webservicex.net/WeatherForecast.asmx?WSDL '
+ url = 'http://jira.atlassian.com/rpc/soap/jirasoapservice-v2?wsdl'
start(url)
client = Client(url)
print client
- print client.service.GetWeatherByZipCode('27606')
+ token = client.service.login('soaptester', 'soaptester')
+ print 'token="%s"' % token
+ user = client.service.getUser(token, 'soaptester')
+ print 'user="%s"' % token
except WebFault, f:
errors += 1
print f
@@ -173,21 +188,6 @@ except Exception, e:
tb.print_exc()
try:
- url = 'http://www.services.coxnewsweb.com/COXnetUR/URService?WSDL'
- start(url)
- client = Client(url)
- print client
- bean = client.service.getUserBean('abc', '123', 'mypassword', 'myusername')
-except WebFault, f:
- errors += 1
- print f
- print f.fault
-except Exception, e:
- errors += 1
- print e
- tb.print_exc()
-
-try:
url = 'http://arcweb.esri.com/services/v2/MapImage.wsdl'
start(url)
client = Client(url)
@@ -250,9 +250,6 @@ try:
timer.stop()
print 'str(client): %s' % timer
print 'client:\n%s' % s
- print 'Account_GetAll()'
- a = client.service.Account_GetAll()
- print a
except WebFault, f:
errors += 1
print f