summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRonny Pfannschmidt <Ronny.Pfannschmidt@gmx.de>2010-05-25 17:25:34 +0200
committerRonny Pfannschmidt <Ronny.Pfannschmidt@gmx.de>2010-05-25 17:25:34 +0200
commit6c964295dbd7ae0b21066c81542b5ca6aea60585 (patch)
treebc70a51ca5651c0c361f7ac21b858ad426ebc488 /setup.py
parent47eda8b31db0bbda48a427c179817b33756e2119 (diff)
downloadsetuptools-scm-6c964295dbd7ae0b21066c81542b5ca6aea60585.tar.gz
add setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 20 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..235f66b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,20 @@
+from setuptools import setup
+import hgdistver
+setup(
+ name='hgdistver',
+ version=hgdistver.get_version(cachefile='hgdistver_version.py'),
+ author_mail='Ronny Pfannschmidt <Ronny.Pfannschmidt@gmx.de>',
+ description='utility lib to generate python package version infos from mercurial tags',
+ long_description=hgdistver.__doc__,
+ license='MIT',
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: Software Development :: Version Control',
+ 'Topic :: System :: Software Distribution',
+ 'Topic :: Utilities',
+ ])
+
+