summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-08-15 14:32:26 -0300
committerMonty Taylor <mordred@inaugust.com>2013-08-15 14:32:26 -0300
commit444fa40f4edb529efbffa2da8dbd97e9b8564b5c (patch)
tree874f71773ac8ada7d257a8baf9af5fc32cf89b11
parent2414ef034a949a4b5d09154df7a7926e67f08840 (diff)
downloadpymox-444fa40f4edb529efbffa2da8dbd97e9b8564b5c.tar.gz
Updated requirements
-rw-r--r--requirements.txt3
-rw-r--r--setup.py5
-rw-r--r--test-requirements.txt7
3 files changed, 7 insertions, 8 deletions
diff --git a/requirements.txt b/requirements.txt
index 437dc75..eb20a59 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,4 +1,3 @@
-d2to1>=0.2.10,<0.3
-pbr>=0.5.10,<0.6
+pbr>=0.5.21,<1.0
fixtures>=0.3.12
diff --git a/setup.py b/setup.py
index b3e85a7..2a0786a 100644
--- a/setup.py
+++ b/setup.py
@@ -14,8 +14,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
setuptools.setup(
- setup_requires=['d2to1>=0.2.10,<0.3', 'pbr>=0.5.10,<0.6'],
- d2to1=True)
+ setup_requires=['pbr>=0.5.21,<1.0'],
+ pbr=True)
diff --git a/test-requirements.txt b/test-requirements.txt
index de5695a..9b993e1 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -1,15 +1,14 @@
# this file lists dependencies required for the testing of heat
-distribute>=0.6.28
# Install bounded pep8/pyflakes first, then let flake8 install
pep8==1.4.5
pyflakes==0.7.2
flake8==2.0
-hacking>=0.5.3,<0.6
+hacking>=0.5.6,<0.7
coverage>=3.6
discover
fixtures>=0.3.12
python-subunit
-testrepository>=0.0.13
-testtools>=0.9.27
+testrepository>=0.0.17
+testtools>=0.9.32