summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Collins <elic@assurancetechnologies.com>2012-05-02 12:06:13 -0400
committerEli Collins <elic@assurancetechnologies.com>2012-05-02 12:06:13 -0400
commit4e2a1e135dda376a43f3bc078d1d31b05fef7ec3 (patch)
tree5dd9142b8669bdd092577bd6fd0313aae7078562
parent9ab3cc675bb3fde85ab319716942ea1cc4693a4f (diff)
downloadpasslib-4e2a1e135dda376a43f3bc078d1d31b05fef7ec3.tar.gz
updated index entries
-rw-r--r--CHANGES4
-rw-r--r--docs/conf.py1
-rw-r--r--docs/install.rst3
-rw-r--r--docs/lib/passlib.apache.rst4
-rw-r--r--docs/lib/passlib.apps.rst10
-rw-r--r--docs/lib/passlib.exc.rst3
-rw-r--r--docs/lib/passlib.ext.django.rst2
-rw-r--r--docs/lib/passlib.hash.apr_md5_crypt.rst2
-rw-r--r--docs/lib/passlib.hash.atlassian_pbkdf2_sha1.rst2
-rw-r--r--docs/lib/passlib.hash.bcrypt.rst3
-rw-r--r--docs/lib/passlib.hash.cisco_pix.rst2
-rw-r--r--docs/lib/passlib.hash.cisco_type7.rst2
-rw-r--r--docs/lib/passlib.hash.cta_pbkdf2_sha1.rst2
-rw-r--r--docs/lib/passlib.hash.django_std.rst2
-rw-r--r--docs/lib/passlib.hash.lmhash.rst2
-rw-r--r--docs/lib/passlib.hash.md5_crypt.rst2
-rw-r--r--docs/lib/passlib.hash.msdcc.rst5
-rw-r--r--docs/lib/passlib.hash.msdcc2.rst3
-rw-r--r--docs/lib/passlib.hash.mysql323.rst2
-rw-r--r--docs/lib/passlib.hash.mysql41.rst2
-rw-r--r--docs/lib/passlib.hash.nthash.rst2
-rw-r--r--docs/lib/passlib.hash.phpass.rst2
-rw-r--r--docs/lib/passlib.hash.postgres_md5.rst2
-rw-r--r--docs/lib/passlib.hash.sun_md5_crypt.rst2
-rw-r--r--docs/new_app_quickstart.rst2
-rw-r--r--docs/password_hash_api.rst21
-rw-r--r--passlib/exc.py7
27 files changed, 63 insertions, 33 deletions
diff --git a/CHANGES b/CHANGES
index c8a2235..1cc1a95 100644
--- a/CHANGES
+++ b/CHANGES
@@ -126,8 +126,8 @@ Existing Hashes
The BCrypt hash now supports the `crypt_blowfish <http://www.openwall.com/crypt/>`_ project's
``$2y$`` hash prefix.
- As well, Passlib now offers an (experimental) pure-python implementation
- of BCrypt. Unfortunately, it's still *way too slow* to be
+ On an unrelated note, Passlib now offers an (experimental) pure-python
+ implementation of BCrypt. Unfortunately, it's still *WAY* too slow to be
suitable for production use; and is disabled by default.
If you really need it, see the BCrypt :ref:`documentation <bcrypt-backends>`
for how to enable it.
diff --git a/docs/conf.py b/docs/conf.py
index 4151274..f1f6f3b 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -150,6 +150,7 @@ if html_theme in ['cloud', 'redcloud']:
html_theme_options['googleanalytics_path'] = '/passlib/'
else:
html_theme_options = {}
+html_theme_options.update(issueicon=r'"\21D7"')
# Add any paths that contain custom themes here, relative to this directory.
html_theme_path = [csp.get_theme_dir()]
diff --git a/docs/install.rst b/docs/install.rst
index d09c862..78c4149 100644
--- a/docs/install.rst
+++ b/docs/install.rst
@@ -50,7 +50,8 @@ To install from a source directory using :command:`setup.py`::
python setup.py install
-.. index:: environmental variable; PASSLIB_TEST_MODE
+.. index::
+ pair: environmental variable; PASSLIB_TEST_MODE
.. rst-class:: html-toggle
diff --git a/docs/lib/passlib.apache.rst b/docs/lib/passlib.apache.rst
index 19779b7..60cb954 100644
--- a/docs/lib/passlib.apache.rst
+++ b/docs/lib/passlib.apache.rst
@@ -16,7 +16,7 @@ htpasswd and htdigest files; though the use of two helper classes.
No more backwards-incompatible changes are currently planned
for these classes.
-.. index:: apache; htpasswd
+.. index:: Apache; htpasswd
Htpasswd Files
==============
@@ -54,7 +54,7 @@ A quick summary of it's usage::
.. autoclass:: HtpasswdFile(path=None, new=False, autosave=False, ...)
-.. index:: apache; htdigest
+.. index:: Apache; htdigest
Htdigest Files
==============
diff --git a/docs/lib/passlib.apps.rst b/docs/lib/passlib.apps.rst
index 90a9624..ea47730 100644
--- a/docs/lib/passlib.apps.rst
+++ b/docs/lib/passlib.apps.rst
@@ -40,7 +40,7 @@ Verifying a password against an existing hash is just as quick::
and :ref:`CryptContext Reference <context-reference>`
for more information about the CryptContext class.
-.. index:: django; crypt context
+.. index:: Django; crypt context
.. _django-contexts:
@@ -116,7 +116,7 @@ Passlib provides two contexts related to ldap hashes:
This object recognizes all the standard ldap schemes that :data:`!ldap_context`
does, *except* for the ``{CRYPT}``-based schemes.
-.. index:: mysql; crypt context
+.. index:: MySQL; crypt context
.. _mysql-contexts:
@@ -141,7 +141,7 @@ for handling MySQL user passwords:
This should be used only with MySQL version 3.2.3 - 4.0.
-.. index:: drupal; crypt context, wordpress; crypt context, phpbb3; crypt context, phpass; crypt context
+.. index:: Drupal; crypt context, Wordpress; crypt context, phpBB3; crypt context, PHPass; crypt context
PHPass
======
@@ -168,7 +168,7 @@ It is found in a wide range of PHP applications, including Drupal and Wordpress.
This object supports phpbb3 password hashes, which use a variant of :class:`~passlib.hash.phpass`.
-.. index:: postgres; crypt context
+.. index:: Postgres; crypt context
PostgreSQL
==========
@@ -197,7 +197,7 @@ PostgreSQL
<traceback omitted>
TypeError: user must be unicode or bytes, not None
-.. index:: roundup; crypt context
+.. index:: Roundup; crypt context
Roundup
=======
diff --git a/docs/lib/passlib.exc.rst b/docs/lib/passlib.exc.rst
index a2bbd8d..96be468 100644
--- a/docs/lib/passlib.exc.rst
+++ b/docs/lib/passlib.exc.rst
@@ -12,7 +12,8 @@ Exceptions
==========
.. autoexception:: MissingBackendError
-.. index:: environmental variable; PASSLIB_MAX_PASSWORD_SIZE
+.. index::
+ pair: environmental variable; PASSLIB_MAX_PASSWORD_SIZE
.. autoexception:: PasswordSizeError
diff --git a/docs/lib/passlib.ext.django.rst b/docs/lib/passlib.ext.django.rst
index 56f9487..7905d3f 100644
--- a/docs/lib/passlib.ext.django.rst
+++ b/docs/lib/passlib.ext.django.rst
@@ -1,4 +1,4 @@
-.. index:: django; password hashing plugin
+.. index:: Django; password hashing plugin
.. module:: passlib.ext.django
diff --git a/docs/lib/passlib.hash.apr_md5_crypt.rst b/docs/lib/passlib.hash.apr_md5_crypt.rst
index 2c67de5..c441765 100644
--- a/docs/lib/passlib.hash.apr_md5_crypt.rst
+++ b/docs/lib/passlib.hash.apr_md5_crypt.rst
@@ -1,4 +1,4 @@
-.. index:: apache; md5 password hash
+.. index:: Apache; md5 password hash
======================================================================
:class:`passlib.hash.apr_md5_crypt` - Apache's MD5-Crypt variant
diff --git a/docs/lib/passlib.hash.atlassian_pbkdf2_sha1.rst b/docs/lib/passlib.hash.atlassian_pbkdf2_sha1.rst
index a725cbe..c240127 100644
--- a/docs/lib/passlib.hash.atlassian_pbkdf2_sha1.rst
+++ b/docs/lib/passlib.hash.atlassian_pbkdf2_sha1.rst
@@ -3,7 +3,7 @@
===========================================================================
.. index::
- pair: atlassian; pbkdf2 hash
+ pair: Atlassian; pbkdf2 hash
.. currentmodule:: passlib.hash
diff --git a/docs/lib/passlib.hash.bcrypt.rst b/docs/lib/passlib.hash.bcrypt.rst
index 9c7b339..a44a121 100644
--- a/docs/lib/passlib.hash.bcrypt.rst
+++ b/docs/lib/passlib.hash.bcrypt.rst
@@ -42,7 +42,8 @@ Interface
.. _bcrypt-backends:
-.. index:: environmental variable; PASSLIB_BUILTIN_BCRYPT
+.. index::
+ pair: environmental variable; PASSLIB_BUILTIN_BCRYPT
.. note::
diff --git a/docs/lib/passlib.hash.cisco_pix.rst b/docs/lib/passlib.hash.cisco_pix.rst
index a6327a7..cffd0a1 100644
--- a/docs/lib/passlib.hash.cisco_pix.rst
+++ b/docs/lib/passlib.hash.cisco_pix.rst
@@ -1,4 +1,4 @@
-.. index:: cisco; pix hash
+.. index:: Cisco; PIX hash
==================================================================
:class:`passlib.hash.cisco_pix` - Cisco PIX hash
diff --git a/docs/lib/passlib.hash.cisco_type7.rst b/docs/lib/passlib.hash.cisco_type7.rst
index e1efc80..dee0a70 100644
--- a/docs/lib/passlib.hash.cisco_type7.rst
+++ b/docs/lib/passlib.hash.cisco_type7.rst
@@ -1,4 +1,4 @@
-.. index:: cisco; type 7 hash
+.. index:: Cisco; Type 7 hash
==================================================================
:class:`passlib.hash.cisco_type7` - Cisco "Type 7" hash
diff --git a/docs/lib/passlib.hash.cta_pbkdf2_sha1.rst b/docs/lib/passlib.hash.cta_pbkdf2_sha1.rst
index f8136bc..2acc2a6 100644
--- a/docs/lib/passlib.hash.cta_pbkdf2_sha1.rst
+++ b/docs/lib/passlib.hash.cta_pbkdf2_sha1.rst
@@ -2,7 +2,7 @@
:class:`passlib.hash.cta_pbkdf2_sha1` - Cryptacular's PBKDF2 hash
=================================================================
-.. index:: pbkdf2 hash; cryptacular
+.. index:: pbkdf2 hash; Cryptacular
.. currentmodule:: passlib.hash
diff --git a/docs/lib/passlib.hash.django_std.rst b/docs/lib/passlib.hash.django_std.rst
index 1b76383..c92e5d6 100644
--- a/docs/lib/passlib.hash.django_std.rst
+++ b/docs/lib/passlib.hash.django_std.rst
@@ -1,4 +1,4 @@
-.. index:: django; hash formats
+.. index:: Django; hash formats
=============================================================
:samp:`passlib.hash.django_{digest}` - Django-specific Hashes
diff --git a/docs/lib/passlib.hash.lmhash.rst b/docs/lib/passlib.hash.lmhash.rst
index eb3123b..04012b9 100644
--- a/docs/lib/passlib.hash.lmhash.rst
+++ b/docs/lib/passlib.hash.lmhash.rst
@@ -1,4 +1,4 @@
-.. index:: lan manager; hash, windows; lan manager hash
+.. index:: LAN Manager hash, Windows; LAN Manager hash
==================================================================
:class:`passlib.hash.lmhash` - LanManager Hash
diff --git a/docs/lib/passlib.hash.md5_crypt.rst b/docs/lib/passlib.hash.md5_crypt.rst
index 5796cd5..fefae6b 100644
--- a/docs/lib/passlib.hash.md5_crypt.rst
+++ b/docs/lib/passlib.hash.md5_crypt.rst
@@ -1,4 +1,4 @@
-.. index:: cisco; type 5 hash
+.. index:: Cisco; Type 5 hash
==================================================================
:class:`passlib.hash.md5_crypt` - MD5 Crypt
diff --git a/docs/lib/passlib.hash.msdcc.rst b/docs/lib/passlib.hash.msdcc.rst
index 864bd46..085ebb5 100644
--- a/docs/lib/passlib.hash.msdcc.rst
+++ b/docs/lib/passlib.hash.msdcc.rst
@@ -1,4 +1,7 @@
-.. index:: msdcc; Windows; Domain Cached Credentials
+.. index::
+ single: Windows; Domain Cached Credentials
+ see: mscash; msdcc
+ see: mscache; msdcc
======================================================================
:class:`passlib.hash.msdcc` - Windows' Domain Cached Credentials
diff --git a/docs/lib/passlib.hash.msdcc2.rst b/docs/lib/passlib.hash.msdcc2.rst
index 016cf81..f63f4a0 100644
--- a/docs/lib/passlib.hash.msdcc2.rst
+++ b/docs/lib/passlib.hash.msdcc2.rst
@@ -1,4 +1,5 @@
-.. index:: msdcc; Windows; Domain Cached Credentials v2
+.. index::
+ single: Windows; Domain Cached Credentials v2
======================================================================
:class:`passlib.hash.msdcc2` - Windows' Domain Cached Credentials v2
diff --git a/docs/lib/passlib.hash.mysql323.rst b/docs/lib/passlib.hash.mysql323.rst
index eda604d..8182b8f 100644
--- a/docs/lib/passlib.hash.mysql323.rst
+++ b/docs/lib/passlib.hash.mysql323.rst
@@ -1,4 +1,4 @@
-.. index:: mysql; OLD_PASSWORD()
+.. index:: MySQL; OLD_PASSWORD()
========================================================================
:class:`passlib.hash.mysql323` - MySQL 3.2.3 password hash
diff --git a/docs/lib/passlib.hash.mysql41.rst b/docs/lib/passlib.hash.mysql41.rst
index 4b9c0db..bf3f9b1 100644
--- a/docs/lib/passlib.hash.mysql41.rst
+++ b/docs/lib/passlib.hash.mysql41.rst
@@ -1,4 +1,4 @@
-.. index:: mysql; PASSWORD()
+.. index:: MySQL; PASSWORD()
=====================================================================
:class:`passlib.hash.mysql41` - MySQL 4.1 password hash
diff --git a/docs/lib/passlib.hash.nthash.rst b/docs/lib/passlib.hash.nthash.rst
index da58f9c..d85b7ac 100644
--- a/docs/lib/passlib.hash.nthash.rst
+++ b/docs/lib/passlib.hash.nthash.rst
@@ -1,4 +1,4 @@
-.. index:: windows; nt hash
+.. index:: Windows; NT hash
==================================================================
:class:`passlib.hash.nthash` - Windows' NT-HASH
diff --git a/docs/lib/passlib.hash.phpass.rst b/docs/lib/passlib.hash.phpass.rst
index 17c357b..66d79de 100644
--- a/docs/lib/passlib.hash.phpass.rst
+++ b/docs/lib/passlib.hash.phpass.rst
@@ -1,4 +1,4 @@
-.. index:: phpass; portable hash, phpbb3; phpass hash
+.. index:: PHPass; portable hash, phpBB3; PHPass hash
==================================================================
:class:`passlib.hash.phpass` - PHPass' Portable Hash
diff --git a/docs/lib/passlib.hash.postgres_md5.rst b/docs/lib/passlib.hash.postgres_md5.rst
index b9e6200..cddaae1 100644
--- a/docs/lib/passlib.hash.postgres_md5.rst
+++ b/docs/lib/passlib.hash.postgres_md5.rst
@@ -1,4 +1,4 @@
-.. index:: postgres; md5 hash
+.. index:: Postgres; md5 hash
==================================================================
:class:`passlib.hash.postgres_md5` - PostgreSQL MD5 password hash
diff --git a/docs/lib/passlib.hash.sun_md5_crypt.rst b/docs/lib/passlib.hash.sun_md5_crypt.rst
index deba896..956cdee 100644
--- a/docs/lib/passlib.hash.sun_md5_crypt.rst
+++ b/docs/lib/passlib.hash.sun_md5_crypt.rst
@@ -1,4 +1,4 @@
-.. index:: solaris; sun_md5_crypt
+.. index:: Solaris; sun_md5_crypt
=================================================================
:class:`passlib.hash.sun_md5_crypt` - Sun MD5 Crypt
diff --git a/docs/new_app_quickstart.rst b/docs/new_app_quickstart.rst
index 98097dc..4824fac 100644
--- a/docs/new_app_quickstart.rst
+++ b/docs/new_app_quickstart.rst
@@ -159,7 +159,7 @@ standard format for encoding password hashes using this algorithm
the external M2Crypto package to speed up PBKDF2 calculations,
though this is not required.
-.. index:: scrypt; status of
+.. index:: SCrypt; status of
What about SCrypt?
..................
diff --git a/docs/password_hash_api.rst b/docs/password_hash_api.rst
index 0bc2476..3aef350 100644
--- a/docs/password_hash_api.rst
+++ b/docs/password_hash_api.rst
@@ -435,6 +435,9 @@ the hashes in passlib:
the specific settings the hash uses, the following keywords should have
roughly the same behavior for all the hashes that support them:
+ .. index::
+ single: salt; PasswordHash keyword
+
``salt``
Specifies a fixed salt string to use, rather than randomly
generating one.
@@ -447,6 +450,9 @@ the hashes in passlib:
:class:`!bytes` instance, with additional constraints
appropriate to the algorithm.
+ .. index::
+ single: salt_size; PasswordHash keyword
+
``salt_size``
Most algorithms which support the ``salt`` setting will
@@ -455,6 +461,9 @@ the hashes in passlib:
the size of salt which should be generated. If omitted,
the hash's default salt size will be used.
+ .. index::
+ single: rounds; PasswordHash keyword
+
``rounds``
If present, this means the hash can vary the number
of internal rounds used in some part of it's algorithm,
@@ -470,6 +479,9 @@ the hashes in passlib:
are periodically retuned to strike a balance between
security and responsiveness.
+ .. index::
+ single: ident; PasswordHash keyword
+
``ident``
If present, the class supports multiple formats for encoding
the same hash. The class's documentation will generally list
@@ -479,6 +491,9 @@ the hashes in passlib:
revision of the hash algorithm itself, and they may not all
offer the same level of security.
+ .. index::
+ single: relaxed; PasswordHash keyword
+
``relaxed``
By default, passing :meth:`~PasswordHash.encrypt` an invalid
value will result in a :exc:`ValueError`. However, if ``relaxed=True``,
@@ -508,6 +523,9 @@ the hashes in passlib:
the following keywords should have roughly the same behavior
for all the hashes that support them:
+ .. index::
+ single: user; PasswordHash keyword
+
``user``
If present, the class requires a username be specified whenever
@@ -515,6 +533,9 @@ the hashes in passlib:
:class:`~passlib.hash.postgres_md5` and
:class:`~passlib.hash.oracle10`).
+ .. index::
+ single: encoding; PasswordHash keyword
+
``encoding``
Some hashes have poorly-defined or host-dependant unicode behavior,
diff --git a/passlib/exc.py b/passlib/exc.py
index 565b1aa..f117bbe 100644
--- a/passlib/exc.py
+++ b/passlib/exc.py
@@ -7,9 +7,9 @@ class MissingBackendError(RuntimeError):
or if specifically requested backend is not available.
:exc:`!MissingBackendError` derives
- from :exc:`RuntimeError`, since this usually indicates
+ from :exc:`RuntimeError`, since it usually indicates
lack of an external library or OS feature.
- This is primarily raised by handlers which depend on
+ This is primarily raised by handlers which depend on
external libraries -- which is currently just
:class:`~passlib.hash.bcrypt`.
"""
@@ -23,7 +23,8 @@ class PasswordSizeError(ValueError):
a potential denial of service (DOS) situation if a maliciously large
password is provided to an application. Because of this, Passlib enforces
a maximum size limit, but one which should be *much* larger
- than any legitimate password.
+ than any legitimate password. :exc:`!PasswordSizeError` derives
+ from :exc:`!ValueError`.
.. note::
Applications wishing to use a different limit should set the