summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Terry <michael.terry@canonical.com>2012-08-31 17:52:09 -0400
committerMichael Terry <michael.terry@canonical.com>2012-08-31 17:52:09 -0400
commit95c24638a73e895fb42449b876266b8029b752bb (patch)
tree5c3d3caefe5aa037dc1670f5f7116407b8b371e3 /setup.py
parentdcbc028f2af02cb1a9c54faedf0defca9841c048 (diff)
downloadoauthlib-95c24638a73e895fb42449b876266b8029b752bb.tar.gz
Support Python 3
These are mostly unicode string related changes and a few syntax ones. https://github.com/idan/oauthlib/issues/55
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index dad02ec..b37f72b 100755
--- a/setup.py
+++ b/setup.py
@@ -13,7 +13,10 @@ def fread(fn):
with open(join(dirname(__file__), fn), 'r') as f:
return f.read()
-tests_require = ['nose', 'unittest2', 'pycrypto']
+if sys.version_info[0] == 3:
+ tests_require = ['nose', 'pycrypto']
+else:
+ tests_require = ['nose', 'unittest2', 'pycrypto']
rsa_require = ['pycrypto']
requires = []