summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Huot <jonathan.huot@thomsonreuters.com>2019-08-06 17:23:22 +0200
committerJonathan Huot <jonathan.huot@thomsonreuters.com>2019-08-06 17:23:22 +0200
commit8d71b161fd145d11c40d55c9ab66ac134a303253 (patch)
tree33191c3fc252264845f108943d006e88206408e6
parent3ce210dc6600385bfec1d7190e879d04801d527b (diff)
downloadoauthlib-8d71b161fd145d11c40d55c9ab66ac134a303253.tar.gz
Add logo to RTD docs & upgraded tox -e readme build to twine.
-rw-r--r--docs/conf.py2
-rw-r--r--docs/logo/oauth-logo-192x192.pngbin0 -> 17744 bytes
-rw-r--r--docs/logo/oauthlib-banner-700x192.pngbin0 -> 69430 bytes
-rw-r--r--docs/logo/oauthlib-banner.xcfbin0 -> 135012 bytes
-rw-r--r--docs/logo/oauthlib-logo-128x128.pngbin0 -> 20040 bytes
-rw-r--r--docs/logo/oauthlib-logo-192x192.pngbin0 -> 31180 bytes
-rw-r--r--docs/logo/oauthlib-logo-256x256.pngbin0 -> 44382 bytes
-rw-r--r--docs/logo/oauthlib-logo-32x32.pngbin0 -> 2237 bytes
-rw-r--r--docs/logo/oauthlib-logo-64x64.pngbin0 -> 5851 bytes
-rw-r--r--docs/logo/oauthlib-logo.pngbin0 -> 220459 bytes
-rw-r--r--docs/logo/python-logo-192x192.pngbin0 -> 6433 bytes
-rwxr-xr-xsetup.py1
-rw-r--r--tox.ini7
13 files changed, 5 insertions, 5 deletions
diff --git a/docs/conf.py b/docs/conf.py
index d18f2aa..3388de6 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -117,7 +117,7 @@ html_theme = 'sphinx_rtd_theme'
# The name of an image file (relative to this directory) to place at the top
# of the sidebar.
-#html_logo = None
+html_logo = "logo/oauthlib-logo-64x64.png"
# The name of an image file (within the static path) to use as favicon of the
# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
diff --git a/docs/logo/oauth-logo-192x192.png b/docs/logo/oauth-logo-192x192.png
new file mode 100644
index 0000000..1f68dce
--- /dev/null
+++ b/docs/logo/oauth-logo-192x192.png
Binary files differ
diff --git a/docs/logo/oauthlib-banner-700x192.png b/docs/logo/oauthlib-banner-700x192.png
new file mode 100644
index 0000000..f29d5ef
--- /dev/null
+++ b/docs/logo/oauthlib-banner-700x192.png
Binary files differ
diff --git a/docs/logo/oauthlib-banner.xcf b/docs/logo/oauthlib-banner.xcf
new file mode 100644
index 0000000..2c11b3f
--- /dev/null
+++ b/docs/logo/oauthlib-banner.xcf
Binary files differ
diff --git a/docs/logo/oauthlib-logo-128x128.png b/docs/logo/oauthlib-logo-128x128.png
new file mode 100644
index 0000000..cabf1e7
--- /dev/null
+++ b/docs/logo/oauthlib-logo-128x128.png
Binary files differ
diff --git a/docs/logo/oauthlib-logo-192x192.png b/docs/logo/oauthlib-logo-192x192.png
new file mode 100644
index 0000000..821d3e6
--- /dev/null
+++ b/docs/logo/oauthlib-logo-192x192.png
Binary files differ
diff --git a/docs/logo/oauthlib-logo-256x256.png b/docs/logo/oauthlib-logo-256x256.png
new file mode 100644
index 0000000..d1dc343
--- /dev/null
+++ b/docs/logo/oauthlib-logo-256x256.png
Binary files differ
diff --git a/docs/logo/oauthlib-logo-32x32.png b/docs/logo/oauthlib-logo-32x32.png
new file mode 100644
index 0000000..83d14ca
--- /dev/null
+++ b/docs/logo/oauthlib-logo-32x32.png
Binary files differ
diff --git a/docs/logo/oauthlib-logo-64x64.png b/docs/logo/oauthlib-logo-64x64.png
new file mode 100644
index 0000000..f5054ac
--- /dev/null
+++ b/docs/logo/oauthlib-logo-64x64.png
Binary files differ
diff --git a/docs/logo/oauthlib-logo.png b/docs/logo/oauthlib-logo.png
new file mode 100644
index 0000000..883a550
--- /dev/null
+++ b/docs/logo/oauthlib-logo.png
Binary files differ
diff --git a/docs/logo/python-logo-192x192.png b/docs/logo/python-logo-192x192.png
new file mode 100644
index 0000000..22aa240
--- /dev/null
+++ b/docs/logo/python-logo-192x192.png
Binary files differ
diff --git a/setup.py b/setup.py
index 3f822e0..1de8510 100755
--- a/setup.py
+++ b/setup.py
@@ -28,6 +28,7 @@ setup(
version=oauthlib.__version__,
description='A generic, spec-compliant, thorough implementation of the OAuth request-signing logic',
long_description=fread('README.rst'),
+ long_description_content_type='text/x-rst',
author='The OAuthlib Community',
author_email='idan@gazit.me',
maintainer='Ib Lundgren',
diff --git a/tox.ini b/tox.ini
index 60b0825..4670c91 100644
--- a/tox.ini
+++ b/tox.ini
@@ -22,12 +22,11 @@ commands=make clean html
# tox -e readme to mimick PyPI long_description check
[testenv:readme]
-skipsdist=True
-deps=readme
+basepython=python3.7
+deps=twine>=1.12.0
whitelist_externals=echo
commands=
- python setup.py check -r -s
- echo setup.py/long description is syntaxly correct
+ twine check dist/*
[testenv:bandit]
basepython=python2.7