summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Huot <JonathanHuot@users.noreply.github.com>2020-04-22 16:24:38 +0200
committerGitHub <noreply@github.com>2020-04-22 16:24:38 +0200
commit406653fc3018b8ae292234caef6df434cf612a52 (patch)
treee7dc3844024d38021ba4edc4fb6dbb55a85d2e56
parent82544c2034987080ad6e11c3f1efe7378467c57b (diff)
parentaf5ac6d7da7aaad09ab5ffeb31a2972aaffe3e2f (diff)
downloadoauthlib-406653fc3018b8ae292234caef6df434cf612a52.tar.gz
Merge pull request #705 from oauthlib/doc-sponsor
-rw-r--r--.github/FUNDING.yml2
-rw-r--r--docs/contributing.rst17
-rw-r--r--tox.ini2
3 files changed, 17 insertions, 4 deletions
diff --git a/.github/FUNDING.yml b/.github/FUNDING.yml
index 9d4faec..a77947b 100644
--- a/.github/FUNDING.yml
+++ b/.github/FUNDING.yml
@@ -1,6 +1,6 @@
# These are supported funding model platforms
-github: # Replace with up to 4 GitHub Sponsors-enabled usernames e.g., [user1, user2]
+github: [JonathanHuot]
patreon: # Replace with a single Patreon username
open_collective: # Replace with a single Open Collective username
ko_fi: # Replace with a single Ko-fi username
diff --git a/docs/contributing.rst b/docs/contributing.rst
index 4a46e3b..eed3866 100644
--- a/docs/contributing.rst
+++ b/docs/contributing.rst
@@ -188,7 +188,7 @@ submit a breaking change, confirm that other projects builds are not affected.
$ make
-If you add code you need to add tests!
+If you add code, add tests!
--------------------------------------
We've learned the hard way that code without tests is undependable. If your pull
@@ -303,7 +303,7 @@ First we pull the code into a local branch::
Then we run the tests::
- pytest
+ tox
We finish with a non-fastforward merge (to preserve the branch history) and push
to GitHub::
@@ -312,6 +312,19 @@ to GitHub::
git merge --no-ff <branch-name>
git push upstream master
+Sponsoring
+==========
+
+The OAuthlib project is open to sponsoring.
+
+As a sponsor, you can participate by clicking on the "Sponsor" button in
+the https://github.com/oauthlib/oauthlib homepage.
+
+As a contributor, you can adhere to the sponsoring program. Feel free
+to open a PR by adding your name into the ``.github/FUNDING.yml``
+file.
+
+
.. _installation: install.html
.. _GitHub project: https://github.com/oauthlib/oauthlib
.. _issue tracker: https://github.com/oauthlib/oauthlib/issues
diff --git a/tox.ini b/tox.ini
index abb72ca..32cd5bf 100644
--- a/tox.ini
+++ b/tox.ini
@@ -9,7 +9,7 @@ commands=
# tox -e docs to mimick readthedocs build.
-# as of today, RTD is using python2.7 and doesn't run "setup.py install"
+# as of today, RTD is using python3.6 and doesn't run "setup.py install"
[testenv:docs]
basepython=python3.6
skipsdist=True