summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Huot <JonathanHuot@users.noreply.github.com>2020-04-22 16:25:12 +0200
committerGitHub <noreply@github.com>2020-04-22 16:25:12 +0200
commit3e582846591e213ba8ec1780a5a5aadf69a090a2 (patch)
tree3ebf7d0a8b521f91a769e1f31c9bf8d4cc75e110
parent22210982dcbaf56a9151a451ab349ab2a51f42f3 (diff)
parent406653fc3018b8ae292234caef6df434cf612a52 (diff)
downloadoauthlib-3e582846591e213ba8ec1780a5a5aadf69a090a2.tar.gz
Merge branch 'master' into isort-integration
-rw-r--r--.github/FUNDING.yml2
-rw-r--r--docs/contributing.rst17
-rw-r--r--examples/skeleton_oauth2_web_application_server.py9
-rw-r--r--tox.ini2
4 files changed, 24 insertions, 6 deletions
diff --git a/.github/FUNDING.yml b/.github/FUNDING.yml
index 9d4faec..a77947b 100644
--- a/.github/FUNDING.yml
+++ b/.github/FUNDING.yml
@@ -1,6 +1,6 @@
# These are supported funding model platforms
-github: # Replace with up to 4 GitHub Sponsors-enabled usernames e.g., [user1, user2]
+github: [JonathanHuot]
patreon: # Replace with a single Patreon username
open_collective: # Replace with a single Open Collective username
ko_fi: # Replace with a single Ko-fi username
diff --git a/docs/contributing.rst b/docs/contributing.rst
index 4a46e3b..eed3866 100644
--- a/docs/contributing.rst
+++ b/docs/contributing.rst
@@ -188,7 +188,7 @@ submit a breaking change, confirm that other projects builds are not affected.
$ make
-If you add code you need to add tests!
+If you add code, add tests!
--------------------------------------
We've learned the hard way that code without tests is undependable. If your pull
@@ -303,7 +303,7 @@ First we pull the code into a local branch::
Then we run the tests::
- pytest
+ tox
We finish with a non-fastforward merge (to preserve the branch history) and push
to GitHub::
@@ -312,6 +312,19 @@ to GitHub::
git merge --no-ff <branch-name>
git push upstream master
+Sponsoring
+==========
+
+The OAuthlib project is open to sponsoring.
+
+As a sponsor, you can participate by clicking on the "Sponsor" button in
+the https://github.com/oauthlib/oauthlib homepage.
+
+As a contributor, you can adhere to the sponsoring program. Feel free
+to open a PR by adding your name into the ``.github/FUNDING.yml``
+file.
+
+
.. _installation: install.html
.. _GitHub project: https://github.com/oauthlib/oauthlib
.. _issue tracker: https://github.com/oauthlib/oauthlib/issues
diff --git a/examples/skeleton_oauth2_web_application_server.py b/examples/skeleton_oauth2_web_application_server.py
index 9a30373..91859fc 100644
--- a/examples/skeleton_oauth2_web_application_server.py
+++ b/examples/skeleton_oauth2_web_application_server.py
@@ -54,13 +54,18 @@ class SkeletonValidator(RequestValidator):
# Token request
+ def client_authentication_required(self, request, *args, **kwargs):
+ # Check if the client provided authentication information that needs to
+ # be validated, e.g. HTTP Basic auth
+ pass
+
def authenticate_client(self, request, *args, **kwargs):
# Whichever authentication method suits you, HTTP Basic might work
pass
def authenticate_client_id(self, client_id, request, *args, **kwargs):
- # Don't allow public (non-authenticated) clients
- return False
+ # The client_id must match an existing public (non-confidential) client
+ pass
def validate_code(self, client_id, code, client, request, *args, **kwargs):
# Validate the code belongs to the client. Add associated scopes
diff --git a/tox.ini b/tox.ini
index 8ff73f2..aad4538 100644
--- a/tox.ini
+++ b/tox.ini
@@ -9,7 +9,7 @@ commands=
# tox -e docs to mimick readthedocs build.
-# as of today, RTD is using python2.7 and doesn't run "setup.py install"
+# as of today, RTD is using python3.6 and doesn't run "setup.py install"
[testenv:docs]
basepython=python3.6
skipsdist=True