summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml87
1 files changed, 23 insertions, 64 deletions
diff --git a/appveyor.yml b/appveyor.yml
index caf19644..45a61d13 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,83 +1,42 @@
environment:
-
- global:
- # SDK v7.0 MSVC Express 2008's SetEnv.cmd script will fail if the
- # /E:ON and /V:ON options are not enabled in the batch script intepreter
- # See: http://stackoverflow.com/a/13751649/163740
- WITH_COMPILER: "cmd /E:ON /V:ON /C .\\extra\\appveyor\\run_with_compiler.cmd"
-
matrix:
+ - TOXENV: "2.7"
+ TOX_APPVEYOR_X64: 0
- # Pre-installed Python versions, which Appveyor may upgrade to
- # a later point release.
- # See: http://www.appveyor.com/docs/installed-software#python
-
- - PYTHON: "C:\\Python27"
- PYTHON_VERSION: "2.7.x"
- PYTHON_ARCH: "32"
+ - TOXENV: "3.4"
+ TOX_APPVEYOR_X64: 0
- - PYTHON: "C:\\Python34"
- PYTHON_VERSION: "3.4.x"
- PYTHON_ARCH: "32"
+ - TOXENV: "3.5"
+ TOX_APPVEYOR_X64: 0
- - PYTHON: "C:\\Python35"
- PYTHON_VERSION: "3.5.x"
- PYTHON_ARCH: "32"
+ - TOXENV: "3.6"
+ TOX_APPVEYOR_X64: 0
- - PYTHON: "C:\\Python36"
- PYTHON_VERSION: "3.6.x"
- PYTHON_ARCH: "32"
+ - TOXENV: "3.7"
+ TOX_APPVEYOR_X64: 0
- - PYTHON: "C:\\Python37"
- PYTHON_VERSION: "3.7.x"
- PYTHON_ARCH: "32"
+ - TOXENV: "2.7"
+ TOX_APPVEYOR_X64: 1
- - PYTHON: "C:\\Python27-x64"
- PYTHON_VERSION: "2.7.x"
- PYTHON_ARCH: "64"
- WINDOWS_SDK_VERSION: "v7.0"
+ - TOXENV: "3.4"
+ TOX_APPVEYOR_X64: 1
- - PYTHON: "C:\\Python34-x64"
- PYTHON_VERSION: "3.4.x"
- PYTHON_ARCH: "64"
- WINDOWS_SDK_VERSION: "v7.1"
+ - TOXENV: "3.5"
+ TOX_APPVEYOR_X64: 1
- - PYTHON: "C:\\Python35-x64"
- PYTHON_VERSION: "3.5.x"
- PYTHON_ARCH: "64"
- WINDOWS_SDK_VERSION: "v7.1"
+ - TOXENV: "3.6"
+ TOX_APPVEYOR_X64: 1
- - PYTHON: "C:\\Python36-x64"
- PYTHON_VERSION: "3.6.x"
- PYTHON_ARCH: "64"
- WINDOWS_SDK_VERSION: "v7.1"
+ - TOXENV: "3.7"
+ TOX_APPVEYOR_X64: 1
- - PYTHON: "C:\\Python37-x64"
- PYTHON_VERSION: "3.7.x"
- PYTHON_ARCH: "64"
- WINDOWS_SDK_VERSION: "v7.1"
-
-init:
- - "ECHO %PYTHON% %PYTHON_VERSION% %PYTHON_ARCH%"
+build: off
install:
- - "powershell extra\\appveyor\\install.ps1"
- - "%PYTHON%/python -m pip install -U pip setuptools"
- - "%PYTHON%/Scripts/pip.exe install -r requirements/dev.txt"
-
-build: off
+ - "py -3.7 -m pip install -U pip setuptools wheel tox tox-appveyor"
test_script:
- - "%WITH_COMPILER% %PYTHON%/python setup.py test"
-
-after_test:
- - "%WITH_COMPILER% %PYTHON%/python setup.py bdist_wheel"
-
-artifacts:
- - path: dist\*
+ - "py -3.7 -m tox"
cache:
- '%LOCALAPPDATA%\pip\Cache'
-
-#on_success:
-# - TODO: upload the content of dist/*.whl to a public wheelhouse