summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAsk Solem <ask@celeryproject.org>2012-09-12 13:59:29 +0100
committerAsk Solem <ask@celeryproject.org>2012-09-12 13:59:48 +0100
commit2767ebe8514a004b0361318039a2eb4cc781fcb4 (patch)
treeabf6468590261254cf140411a12c3e65425b183e /setup.py
parent8fe0fefc2909695989ef7b356008961ffb080993 (diff)
downloadkombu-2767ebe8514a004b0361318039a2eb4cc781fcb4.tar.gz
Now depends on importlib+ordereddict if used with Python < 2.7, and simplejson if < 2.6
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index e38090bd..d512407f 100644
--- a/setup.py
+++ b/setup.py
@@ -111,6 +111,10 @@ def reqs(f):
os.path.join(os.getcwd(), 'requirements', f)).readlines()])
install_requires = reqs('default.txt')
+if py_version[0:2] == (2, 6):
+ install_requires.extend(reqs('py26.txt'))
+elif py_version[0:2] == (2, 5):
+ install_requires.extend(reqs('py25.txt'))
# -*- Tests Requires -*-
@@ -119,9 +123,6 @@ if is_py3k:
else:
tests_require = reqs('test.txt')
-if py_version[0:2] == (2, 5):
- tests_require.extend('test-py25.txt')
-
setup(
name='kombu',
version=meta['VERSION'],