summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2014-08-04 13:39:29 -0400
committerTimothy Crosley <timothy.crosley@gmail.com>2014-08-04 13:39:29 -0400
commit9d1b03b6e1fd2f87be1c635d6159a76a131f8155 (patch)
treef7f7f887bb94f97d6e3a331d6e007ad110322d66
parent9c61b9b3b3dd6e4776e6339ee2a4a606139e3d5c (diff)
parentb87ca3df0c5557e13952fcf75ec338059ca0bcf0 (diff)
downloadisort-9d1b03b6e1fd2f87be1c635d6159a76a131f8155.tar.gz
Merge branch 'release/3.9.0'3.9.0
-rw-r--r--README.md2
-rw-r--r--isort/__init__.py2
-rwxr-xr-xisort/main.py2
-rw-r--r--isort/settings.py2
-rwxr-xr-xsetup.py4
5 files changed, 7 insertions, 5 deletions
diff --git a/README.md b/README.md
index aa65f947..daa828b6 100644
--- a/README.md
+++ b/README.md
@@ -10,7 +10,7 @@
isort your python imports for you so you don't have to.
isort is a Python utility / library to sort imports alphabetically, and automatically separated into sections.
-It provides a command line utility, Python library and [plugins for various editors](#installing-isorts-for-your-preferred-text-editor) to quickly sort all your imports.
+It provides a command line utility, Python library and [plugins for various editors](https://github.com/timothycrosley/isort/wiki/isort-Plugins) to quickly sort all your imports.
It currently cleanly supports Python 2.6 - 3.4 using pies (https://github.com/timothycrosley/pies) to achieve this without ugly hacks and/or py2to3.
Before isort:
diff --git a/isort/__init__.py b/isort/__init__.py
index 201c8c1f..4dc4cbdd 100644
--- a/isort/__init__.py
+++ b/isort/__init__.py
@@ -25,4 +25,4 @@ from __future__ import absolute_import, division, print_function, unicode_litera
from . import settings
from .isort import SECTION_NAMES, SECTIONS, SortImports
-__version__ = "3.8.3"
+__version__ = "3.9.0"
diff --git a/isort/main.py b/isort/main.py
index e00a0105..fb065eba 100755
--- a/isort/main.py
+++ b/isort/main.py
@@ -98,6 +98,8 @@ def main():
parser.add_argument('-v', '--version', action='version', version='isort {0}'.format(__version__))
parser.add_argument('-vb', '--verbose', action='store_true', dest="verbose",
help='Shows verbose output, such as when files are skipped or when a check is successful.')
+ parser.add_argument('-sp', '--settings-path', dest="settings_path",
+ help='Explicitly set the settings path instead of auto determining based on file location.')
arguments = dict((key, value) for (key, value) in itemsview(vars(parser.parse_args())) if value)
file_names = arguments.pop('files', [])
diff --git a/isort/settings.py b/isort/settings.py
index 3da46f31..96071712 100644
--- a/isort/settings.py
+++ b/isort/settings.py
@@ -43,7 +43,7 @@ WrapModes = namedtuple('WrapModes', WrapModes)(*range(len(WrapModes)))
# Note that none of these lists must be complete as they are simply fallbacks for when included auto-detection fails.
default = {'force_to_top': [],
'skip': ['__init__.py', ],
- 'line_length': 80,
+ 'line_length': 79,
'known_standard_library': ["abc", "anydbm", "argparse", "array", "asynchat", "asyncore", "atexit", "base64",
"BaseHTTPServer", "bisect", "bz2", "calendar", "cgitb", "cmd", "codecs",
"collections", "commands", "compileall", "ConfigParser", "contextlib", "Cookie",
diff --git a/setup.py b/setup.py
index 831f7e98..b7f720ab 100755
--- a/setup.py
+++ b/setup.py
@@ -42,13 +42,13 @@ except (IOError, ImportError, OSError, RuntimeError):
readme = ''
setup(name='isort',
- version='3.8.3',
+ version='3.9.0',
description='A Python utility / library to sort Python imports.',
long_description=readme,
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/isort',
- download_url='https://github.com/timothycrosley/isort/archive/3.8.3.tar.gz',
+ download_url='https://github.com/timothycrosley/isort/archive/3.9.0.tar.gz',
license="MIT",
entry_points={
'console_scripts': [