summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurent Mazuel <lmazuel@microsoft.com>2017-06-28 18:03:51 -0700
committerGitHub <noreply@github.com>2017-06-28 18:03:51 -0700
commit3b359c5ac01308eb086fc7072a5ec4a942d46823 (patch)
tree6c91762d8bac3657c32c26b4f2c3e798ee11b246
parentc99a3d93c5f66971713ccddeff21dcc865e0c9af (diff)
downloadisodate-3b359c5ac01308eb086fc7072a5ec4a942d46823.tar.gz
Remove 2to3 usage
-rw-r--r--setup.py16
1 files changed, 4 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 44b94a6..2778886 100644
--- a/setup.py
+++ b/setup.py
@@ -30,17 +30,8 @@ import sys
setupargs = {}
-try:
- from setuptools import setup
- setupargs['test_suite'] = 'isodate.tests.test_suite'
- if sys.version[0] == '3':
- setupargs['use_2to3'] = True
-except ImportError:
- from distutils.core import setup
- if sys.version[0] == '3':
- from distutils.command.build_py import build_py_2to3
- setupargs['cmdclass'] = {'build_py': build_py_2to3}
-
+from setuptools import setup
+setupargs['test_suite'] = 'isodate.tests.test_suite'
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
@@ -71,11 +62,12 @@ setup(name='isodate',
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Internet',
('Topic :: Software Development :'