summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Gregorio <jcgregorio@google.com>2015-04-11 09:50:15 -0400
committerJoe Gregorio <jcgregorio@google.com>2015-04-11 09:50:15 -0400
commitf9f797223d075874b0031aea832152688ec23fef (patch)
treec9b70a4847fbc3283ac2efbabc150638d391d3dd
parent1af76a6fedf1eee462ac9b2bedfe44662f70f74e (diff)
downloadhttplib2-f9f797223d075874b0031aea832152688ec23fef.tar.gz
0.9.1 Release changes.v0.9.10.9.1
-rw-r--r--CHANGELOG11
-rw-r--r--python2/httplib2/__init__.py4
-rw-r--r--python3/httplib2/__init__.py2
-rwxr-xr-xsetup.py2
-rwxr-xr-xtest/.htaccess7
5 files changed, 20 insertions, 6 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 6472020..9e6688a 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,5 +1,16 @@
0.9.1
+ Fixes in this release:
+
+ https://github.com/jcgregorio/httplib2/pull/296
+
+ There was a problem with headers when a binary string is passed (like
+ b'Authorization').
+
+ https://github.com/jcgregorio/httplib2/pull/276
+
+ Default to doing DNS resolution through a proxy server if present.
+
0.9
Heartbleed
diff --git a/python2/httplib2/__init__.py b/python2/httplib2/__init__.py
index 9fe28b9..19e7cff 100644
--- a/python2/httplib2/__init__.py
+++ b/python2/httplib2/__init__.py
@@ -22,7 +22,7 @@ __contributors__ = ["Thomas Broyer (t.broyer@ltgt.net)",
"Sam Ruby",
"Louis Nyffenegger"]
__license__ = "MIT"
-__version__ = "0.9"
+__version__ = "0.9.1"
import re
import sys
@@ -1496,7 +1496,7 @@ class Http(object):
info = email.Message.Message()
cached_value = None
if self.cache:
- cachekey = defrag_uri
+ cachekey = defrag_uri.encode('utf-8')
cached_value = self.cache.get(cachekey)
if cached_value:
# info = email.message_from_string(cached_value)
diff --git a/python3/httplib2/__init__.py b/python3/httplib2/__init__.py
index b7b00b1..260fa6b 100644
--- a/python3/httplib2/__init__.py
+++ b/python3/httplib2/__init__.py
@@ -24,7 +24,7 @@ __contributors__ = ["Thomas Broyer (t.broyer@ltgt.net)",
"Louis Nyffenegger",
"Mark Pilgrim"]
__license__ = "MIT"
-__version__ = "0.9"
+__version__ = "0.9.1"
import re
import sys
diff --git a/setup.py b/setup.py
index 5af7a91..4240f6c 100755
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ except ImportError:
import sys
pkgdir = {'': 'python%s' % sys.version_info[0]}
-VERSION = '0.9'
+VERSION = '0.9.1'
setup(name='httplib2',
version=VERSION,
diff --git a/test/.htaccess b/test/.htaccess
index dd39dbc..863f8e4 100755
--- a/test/.htaccess
+++ b/test/.htaccess
@@ -1,5 +1,8 @@
AddHandler cgi-script .asis
-Options +ExecCGI
+Options +ExecCGI +Indexes
ExpiresActive On
ExpiresDefault "access plus 2 hours"
-# removed by cornerhost: SecFilterEngine Off
+<IfModule mod_security.c>
+SecFilterEngine Off
+SecFilterScanPOST off
+</IfModule>