summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrian.quinlan <devnull@localhost>2009-10-25 09:02:47 +0000
committerbrian.quinlan <devnull@localhost>2009-10-25 09:02:47 +0000
commit968b9f884d1db843a600618c1a6e4a09e624df27 (patch)
treedc9f17d496ed0e4411c9a43e18fdece50bd5b53b
parente80dcb9e46dd349541fca90268c7aefd6da66356 (diff)
downloadfutures-968b9f884d1db843a600618c1a6e4a09e624df27.tar.gz
Update the version number and use different targets for python 2.x and 3.x1.0
-rwxr-xr-xpython2/setup.py6
-rwxr-xr-xpython3/setup.py10
2 files changed, 8 insertions, 8 deletions
diff --git a/python2/setup.py b/python2/setup.py
index bc63ee7..378470f 100755
--- a/python2/setup.py
+++ b/python2/setup.py
@@ -3,16 +3,16 @@
from distutils.core import setup
setup(name='futures',
- version='0.2',
+ version='1.0',
description='Java-style futures implementation in Python',
author='Brian Quinlan',
author_email='brian@sweetapp.com',
url='http://code.google.com/p/pythonfutures',
- download_url='http://pypi.python.org/pypi/futures/',
+ download_url='http://pypi.python.org/pypi/futures3/',
packages=['futures'],
license='BSD',
classifiers=['License :: OSI Approved :: BSD License',
- 'Development Status :: 3 - Alpha',
+ 'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
'Programming Language :: Python :: 2']
)
diff --git a/python3/setup.py b/python3/setup.py
index a8d97df..fcd05f2 100755
--- a/python3/setup.py
+++ b/python3/setup.py
@@ -2,17 +2,17 @@
from distutils.core import setup
-setup(name='futures',
- version='0.2',
- description='Java-style futures implementation in Python',
+setup(name='futures3',
+ version='1.0',
+ description='Java-style futures implementation in Python 3.x',
author='Brian Quinlan',
author_email='brian@sweetapp.com',
url='http://code.google.com/p/pythonfutures',
- download_url='http://pypi.python.org/pypi/futures/',
+ download_url='http://pypi.python.org/pypi/futures3/',
packages=['futures'],
license='BSD',
classifiers=['License :: OSI Approved :: BSD License',
- 'Development Status :: 3 - Alpha',
+ 'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
'Programming Language :: Python :: 3']
)