summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2012-09-25 17:26:06 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2012-09-25 17:26:06 -0400
commit950e0ebfb8de9b59c7419dd691a371c85c6f985e (patch)
tree9616bbb094ec2336bda1be4117e2bbcd0eebe5b5
parent878055dda3194381028239dfbadeba55f3201719 (diff)
downloaddogpile-core-950e0ebfb8de9b59c7419dd691a371c85c6f985e.tar.gz
changelogrel_0_3_3
-rw-r--r--CHANGES17
-rw-r--r--dogpile/core/__init__.py2
2 files changed, 12 insertions, 7 deletions
diff --git a/CHANGES b/CHANGES
index 30c849d..f2c7da1 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,8 @@
+0.3.3
+=====
+- repair setup.py so that tests don't install,
+ courtesy Ben Hayden.
+
0.3.2
=====
- upgrade to beta.
@@ -24,18 +29,18 @@
=====
- Add new "nameregistry" helper. Another fixture
- derived from Beaker, this allows the ad-hoc creation of
+ derived from Beaker, this allows the ad-hoc creation of
a new Dogpile lock based on a name, where all other
- threads calling that name at the same time will get
+ threads calling that name at the same time will get
the same Dogpile lock. Allows any number of
logical "dogpile" actions to carry on concurrently
without any memory taken up outside of those operations.
- To support the use case supported by nameregistry, added
- value_and_created_fn to dogpile.acquire(). The idea
- is that the value_and_created_fn can return
- (value, createdtime), so that the creation time of the
- value can come from the cache, thus eliminating the
+ value_and_created_fn to dogpile.acquire(). The idea
+ is that the value_and_created_fn can return
+ (value, createdtime), so that the creation time of the
+ value can come from the cache, thus eliminating the
need for the dogpile lock to hang around persistently.
0.2.0
diff --git a/dogpile/core/__init__.py b/dogpile/core/__init__.py
index 563333e..7de5934 100644
--- a/dogpile/core/__init__.py
+++ b/dogpile/core/__init__.py
@@ -4,5 +4,5 @@ from .readwrite_lock import ReadWriteMutex
__all__ = 'Dogpile', 'SyncReaderDogpile', 'NeedRegenerationException', 'NameRegistry', 'ReadWriteMutex'
-__version__ = '0.3.2'
+__version__ = '0.3.3'