summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2012-10-29 16:15:01 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2012-10-29 16:15:01 -0400
commit093560f57163c5216772c2e6d41e9b709e47b62a (patch)
treeba0fc277069a685280a4aeb6cea102a8ed32f7e3
parent3e3a23a8424fe4aab76012b532698a8085588cf3 (diff)
downloaddogpile-core-093560f57163c5216772c2e6d41e9b709e47b62a.tar.gz
changelog
-rw-r--r--CHANGES20
1 files changed, 20 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index f2c7da1..1786f28 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,23 @@
+0.4.0
+=====
+- reworked Dogpile's API into a new object called Lock.
+ Lock presents just one set of arguments for locking within
+ one constructor call, and provides the "comprehensive" caching
+ pattern that is what's desired in the vast majority of cases.
+ The Dogpile class is now legacy, and
+ builds its various usage patterns on top of Lock.
+
+- Fixed the dependency on storing "creationtime" locally in memory;
+ this caused dogpile pileups for a missing cache value when used in multiple-process
+ environments. The new Lock object now checks the value_and_created_fn()
+ an extra time within the "lock acquired" phase so that multiple writers
+ who entered the block don't rely upon a memory-only version of creation
+ time. #1
+
+- The NameRegistry class is no longer needed for use with Lock,
+ as there is no shared state. The class is still handy and will
+ hang around, however.
+
0.3.3
=====
- repair setup.py so that tests don't install,