summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomi Pieviläinen <hukka@tsume>2013-11-01 10:37:15 +0200
committerTomi Pieviläinen <hukka@tsume>2013-11-01 10:37:15 +0200
commit8c6026ba09716a4e164f5420120bfe2ebb2d9d82 (patch)
treed27eed80f804376de90654f1e67c721a7e1657d0
parente49a25913c5f9e8d818520f1258b42b0a04402f2 (diff)
downloaddateutil-8c6026ba09716a4e164f5420120bfe2ebb2d9d82.tar.gz
Use /usr/bin/env, test for py33 and how to release in README.HEADtrunk
-rw-r--r--README13
-rwxr-xr-xsetup.py1
-rwxr-xr-xtest.py2
-rw-r--r--tox.ini2
-rwxr-xr-xupdatezinfo.py2
5 files changed, 16 insertions, 4 deletions
diff --git a/README b/README
index 6f542d5..b1afd9c 100644
--- a/README
+++ b/README
@@ -1973,7 +1973,8 @@ Example:
tzfile('Brazil/East')
}}}
-== Building ==
+
+== Building and releasing ==
When you get the source, it does not contain the internal zoneinfo
database. To get (and update) the database, run the updatezinfo.py script. Make sure
that the zic command is in your path, and that you have network connectivity
@@ -1981,9 +1982,19 @@ to get the latest timezone information from IANA. If you have downloaded
the timezone data earlier, you can give the tarball as a parameter to
updatezinfo.py.
+After testing any changes, changing the version information in dateutil/__init__.py
+and updating NEWS, a new release can be uploaded to PyPI with
+{{{
+python setup.py sdist upload
+}}}
+
+
== Testing ==
dateutil has a comprehensive test suite, which can be run simply by running the
test.py script in the project root. Note that if you don't have the internal
zoneinfo database, some tests will fail. Apart from that, all tests should pass.
+To easily test dateutil against all supported Python versions, you can use
+[[[http://tox.readthedocs.org/en/latest/ tox]]].
+
## vim:ft=moin
diff --git a/setup.py b/setup.py
index b9a7cf4..b6d8cdf 100755
--- a/setup.py
+++ b/setup.py
@@ -45,6 +45,7 @@ datetime module available in the Python standard library.
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
'Topic :: Software Development :: Libraries',
]
)
diff --git a/test.py b/test.py
index 394992c..0388fbc 100755
--- a/test.py
+++ b/test.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
# -*- encoding: utf-8 -*-
from __future__ import unicode_literals
diff --git a/tox.ini b/tox.ini
index 51c5d99..5d90c1c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26, py27, py32
+envlist = py26, py27, py32, py33
[testenv]
commands = python test.py
diff --git a/updatezinfo.py b/updatezinfo.py
index 46b3cf7..627231a 100755
--- a/updatezinfo.py
+++ b/updatezinfo.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
import os
import re
import sys