summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohan Dahlin <zilch@src.gnome.org>2003-01-18 17:25:25 +0000
committerJohan Dahlin <zilch@src.gnome.org>2003-01-18 17:25:25 +0000
commitf2a49168dd47c12f2545198fec9469c7e80bd2a2 (patch)
tree53153db4abb9fc657de8ac31c09e903e67275f46 /setup.py
parentc3a8eaaa5b87be0be2431df129c155c37dd14fdd (diff)
downloadpygtk-f2a49168dd47c12f2545198fec9469c7e80bd2a2.tar.gz
use os.path.join in a few more places
* setup.py: use os.path.join in a few more places * pygobject-private.h: Add PyGMainLoop struct and type * gobjectmodule.c (_wrap_g_main_loop_new, _wrap_g_main_loop_quit) (_wrap_g_main_loop_is_running, _wrap_g_main_loop_run): Added GMainLoop wrapper. (initgobject): Register wrapper in gobject.MainLoop
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index cc1832ff..c828cef7 100755
--- a/setup.py
+++ b/setup.py
@@ -51,9 +51,9 @@ GLOBAL_MACROS = [('VERSION', '"%s"' % VERSION),
('PYGTK_MINOR_VERSION', MINOR_VERSION),
('PYGTK_MICRO_VERSION', MICRO_VERSION)]
-DEFS_DIR = 'share/pygtk/%s/defs' % PYGTK_SUFFIX
-CODEGEN_DIR = 'share/pygtk/%s/codegen' % PYGTK_SUFFIX
-INCLUDE_DIR = 'include/pygtk-%s' % PYGTK_SUFFIX
+DEFS_DIR = os.path.join('share', 'pygtk', PYGTK_SUFFIX, 'defs')
+CODEGEN_DIR = os.path.join('share', 'pygtk', PYGTK_SUFFIX, 'codegen')
+INCLUDE_DIR = os.path.join('include', 'pygtk-%s' % PYGTK_SUFFIX)
str_version = sys.version[:3]
version = map(int, str_version.split('.'))