summaryrefslogtreecommitdiff
path: root/testsuite/Makefile.am
diff options
context:
space:
mode:
authorCraig Small <csmall@enc.com.au>2011-12-03 00:32:14 +1100
committerCraig Small <csmall@enc.com.au>2011-12-03 00:32:14 +1100
commit3d807ae853b8b4264da156065b34f1447658a8ba (patch)
tree2b16595218c92ad70ff7a34c5e9c061018366ec8 /testsuite/Makefile.am
parent4725fc735e15061344affd07724a454246c0f82c (diff)
downloadprocps-ng-3d807ae853b8b4264da156065b34f1447658a8ba.tar.gz
Minor test fixes for non-linux
procps works well on Linux, on other arches there are some strange differences due to their emulation of procfs which is not 100% Disabling checks for non-linux until that can be sorted out.
Diffstat (limited to 'testsuite/Makefile.am')
-rw-r--r--testsuite/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
index 73df0c2..9374941 100644
--- a/testsuite/Makefile.am
+++ b/testsuite/Makefile.am
@@ -1,17 +1,20 @@
AUTOMAKE_OPTIONS = dejagnu
export DEJAGNU
+if LINUX
+# Programs that are expected across the board
DEJATOOL = \
free \
- kill \
pgrep \
pkill \
- pmap \
ps \
pwdx \
uptime \
vmstat \
- w
+ w \
+ sysctl slabtop pmap kill
+
+endif
EXTRA_DIST = \
@@ -29,4 +32,5 @@ EXTRA_DIST = \
pwdx.test/pwdx.exp \
global-conf.exp \
sysctl.test/sysctl_read.exp \
+ slabtop.test/slabtop.exp \
vmstat.test/vmstat.exp