summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron D. Marasco <github-patchelf@marascos.net>2020-06-10 09:35:06 -0400
committerAaron D. Marasco <github-patchelf@marascos.net>2020-06-10 09:51:37 -0400
commite522b14edc0ef742106771176f13c9a0b78818ca (patch)
treef0f41291fe468146b7813b1da858c209b64e0099 /configure.ac
parentd6b2a72d9ec3bdfde4b1aacdada823ce388968bb (diff)
downloadpatchelf-e522b14edc0ef742106771176f13c9a0b78818ca.tar.gz
Add libasan build option and test print-needed
(cherry picked from commit 288eb61a173ce6f4cdf0be0d744c9c6b6b5598a4)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c2e5e98..e762e1e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,5 +24,10 @@ fi
AC_DEFINE_UNQUOTED(PAGESIZE, ${PAGESIZE})
AC_MSG_RESULT([Setting page size to ${PAGESIZE}])
+AC_ARG_WITH([asan],
+ AS_HELP_STRING([--with-asan], [Link with libasan])
+)
+AM_CONDITIONAL([WITH_ASAN], [test x"$with_asan" = xyes])
+
AC_CONFIG_FILES([Makefile src/Makefile tests/Makefile patchelf.spec])
AC_OUTPUT