summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChuck Short <chuck.short@canonical.com>2012-04-24 13:52:54 -0400
committerMonty Taylor <mordred@inaugust.com>2012-05-04 10:17:36 -0700
commit7ba26ad4ba4c79680fe8d84dbe1fd4395dd2d119 (patch)
treecab0f141090df5b30ea764ecc18bb301112aeb83 /setup.py
parent57a2e6523390c4305b5c2ce26268ebe74a2f25ff (diff)
downloadnova-7ba26ad4ba4c79680fe8d84dbe1fd4395dd2d119.tar.gz
Generate a Changelog for Nova
Ubuntu uses a tarball to generate packages for Nova and other openstack projects. This allows the user to find out what is included in the tarball. Signed-off-by: Chuck Short <chuck.short@canonical.com> Change-Id: I0291e19eee1ff2c5fc98b499571b2563841c6076
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 11 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 32b59511f3..720d73ceca 100644
--- a/setup.py
+++ b/setup.py
@@ -15,15 +15,24 @@
# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
# License for the specific language governing permissions and limitations
# under the License.
-
import glob
import os
import setuptools
+from setuptools.command import sdist
+from nova.openstack.common import setup as common_setup
from nova import version
-nova_cmdclass = {}
+
+class local_sdist(sdist.sdist):
+ """Customized sdist hook - builds the ChangeLog file from VC first."""
+ def run(self):
+ common_setup.write_git_changelog()
+ # sdist.sdist is an old style class, can't user super()
+ sdist.sdist.run(self)
+
+nova_cmdclass = {'sdist': local_sdist}
try:
from sphinx import setup_command