summaryrefslogtreecommitdiff
path: root/cogl/tests/micro-perf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cogl/tests/micro-perf/Makefile.am')
-rw-r--r--cogl/tests/micro-perf/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/cogl/tests/micro-perf/Makefile.am b/cogl/tests/micro-perf/Makefile.am
new file mode 100644
index 000000000..75d02b2ce
--- /dev/null
+++ b/cogl/tests/micro-perf/Makefile.am
@@ -0,0 +1,24 @@
+NULL =
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)
+
+test_conformance_CPPFLAGS = \
+ -DCOGL_ENABLE_EXPERIMENTAL_API \
+ -DCOGL_DISABLE_DEPRECATED \
+ -DTESTS_DATADIR=\""$(top_srcdir)/tests/data"\"
+
+
+noinst_PROGRAMS =
+
+noinst_PROGRAMS += test-journal
+
+AM_CFLAGS = $(COGL_DEP_CFLAGS) $(COGL_EXTRA_CFLAGS)
+
+common_ldadd = \
+ $(COGL_DEP_LIBS) \
+ $(top_builddir)/cogl/libmutter-cogl.la \
+ $(LIBM)
+
+test_journal_SOURCES = test-journal.c
+test_journal_LDADD = $(common_ldadd)