summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2015-03-31 10:38:44 +1000
committerJasper St. Pierre <jstpierre@mecheye.net>2015-06-01 09:38:13 -0700
commitef296031cbf0883135b7a1f436c6a69f75122efe (patch)
treef5a3f86f9eeb11d7712e639297037191246d1a38 /configure.ac
parente2d602892400cdb20c942a3ed2ec79d09c5c0b26 (diff)
downloadmutter-ef296031cbf0883135b7a1f436c6a69f75122efe.tar.gz
backends/x11: add a flag to denote randr 1.5 is in use.
If the server reports randr 1.5, just cache the information for later patches to use.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7cb832b68..88d162a5c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -284,6 +284,8 @@ AC_CHECK_LIB(Xrandr, XRRUpdateConfiguration,
if test "x$found_randr" = "xyes"; then
AC_DEFINE(HAVE_RANDR, , [Have the Xrandr extension library])
+ PKG_CHECK_EXISTS([xrandr >= 1.5.0],
+ AC_DEFINE([HAVE_XRANDR15],[1],[Define if you have support for XRandR 1.5 or greater]))
fi
MUTTER_LIBS="$MUTTER_LIBS $RANDR_LIBS $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS -lm"