summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2013-11-27 21:02:03 +0000
committerRobert Bragg <robert@linux.intel.com>2013-12-11 18:49:19 +0000
commit52a69bb9ab0865d468932077d76cc3e3634c52bb (patch)
treec3f3d1350b73306b078e47bc445eb04a1bd057c3 /Makefile.am
parenta0bc2d96bee55a64a97370ef135c73c41bdffcac (diff)
downloadmutter-52a69bb9ab0865d468932077d76cc3e3634c52bb.tar.gz
Build and install cogl-path as a shared library
Since we now have more time to ensure that Clutter is updated to check for the now separate cogl-path package as part of its build configuration we are now making the package split, in line with Cogl master. Reviewed-by: Neil Roberts <neil@linux.intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index e24041f94..a0c0c76ab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,14 +1,11 @@
SUBDIRS = deps test-fixtures
-# Until we can bump the cogl soname cogl-path is built as
-# a noinst_LTLIBRARY and linked into libcogl.so so it needs
-# to be built before cogl...
+SUBDIRS += cogl
+
if BUILD_COGL_PATH
SUBDIRS += cogl-path
endif
-SUBDIRS += cogl
-
if BUILD_COGL_PANGO
SUBDIRS += cogl-pango
endif