summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@linux.intel.com>2009-05-29 17:50:58 +0100
committerEmmanuele Bassi <ebassi@linux.intel.com>2009-05-29 17:50:58 +0100
commit2f319ad839972a393569d53c87689bdc4a5f55b7 (patch)
tree37c2e6133e69b30ffad238d2f73b017613fac42a /Makefile.am
parent5888e45fd73b3f11de1d0a100cc6072ceb80c1df (diff)
downloadmutter-2f319ad839972a393569d53c87689bdc4a5f55b7.tar.gz
[build] Remove cogl-enum-types.h on distclean
The cogl-enum-types.h file is created by glib-mkenums under /clutter/cogl/common, and then copied in /clutter/cogl in order to make the inclusion of that file work inside cogl.h. Since we're copying it in a different location, the Makefile for that location has to clean up the copy.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5dec59880..cae798703 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,6 +49,10 @@ cogl_headers = \
$(top_builddir)/clutter/cogl/cogl.h \
$(NULL)
+# this is copied in from common/ to make cogl.h work, but we
+# need to clean it up ourselves once we're done
+DISTCLEANFILES = cogl-enum-types.h
+
# HACK - gobject-introspection can't scan a library in another directory
# so we create a libclutter-cogl.la that's just identical to the one
# in the subdir