summaryrefslogtreecommitdiff
path: root/bin/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2018-10-11 13:08:42 +0100
committerEric Engestrom <eric@engestrom.ch>2019-07-10 11:27:51 +0000
commit176f350fcf1d3024482c0307d2ce9eec836ad487 (patch)
tree3652d0ca78e15c454d630ba5d2b21a81331ed14f /bin/meson.build
parent62362a4abb6f068472d12f884f12ba9a2cb2ca0d (diff)
downloadmesa-176f350fcf1d3024482c0307d2ce9eec836ad487.tar.gz
symbols-check: introduce new python script
I've re-written this in bash a couple times over the years, and then I realised python is much more portable and already required by Mesa, so we might as well make use of it. I decided to still use the build system's NM instead of re-implementing symbols extraction, to offload the complexity of keeping it compatible with many systems (Linux, Unix, BSD, MacOS, etc.), especially when cross-building. This new script checks not only that nothing is exported when it shouldn't be, but also that everything that should be exported is. Sometimes, some symbols _can_ be exported but don't have to be, in which case they can be prefixed with `(optional)`. Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'bin/meson.build')
-rw-r--r--bin/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/bin/meson.build b/bin/meson.build
index b8b44baf7d0..ec22e2e2989 100644
--- a/bin/meson.build
+++ b/bin/meson.build
@@ -19,3 +19,4 @@
# SOFTWARE.
git_sha1_gen_py = files('git_sha1_gen.py')
+symbols_check = find_program('symbols-check.py')