summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <gp@n-dimensional.de>2002-05-28 17:00:03 +0000
committerHans Ulrich Niedermann <gp@n-dimensional.de>2002-05-28 17:00:03 +0000
commitef7dde348887a83499020ceb1cc8102813e6c299 (patch)
tree8147e5ad977da607f49d5b9922231bb4a94192ea /doc/Makefile.am
parent091e62e298c97bb0026eade22c407fff28afa76d (diff)
downloadlibgphoto2-ef7dde348887a83499020ceb1cc8102813e6c299.tar.gz
build and install man pages and html manual if possible
git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@4577 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index b783d0ee7..4cae18d17 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -9,7 +9,7 @@ EXTRA_DIST = DAEMON build_OS2.txt \
gphoto2.xml $(man_MANS) \
FAQ
-man_MANS = gphoto2.1 gphoto2.3
+man_MANS = gphoto2.1 gphoto2.3 gphoto2_port.3
docdir = @DOC_DIR@
@@ -19,12 +19,27 @@ doc_DATA = gphoto2-cli.txt gphoto2.txt FAQ
# This requires xmlto, which can be obtained from
# <http://cyberelk.net/tim/xmlto/>.
if XMLTOMAN
+all-local: $(man_MANS)
+
$(man_MANS): gphoto2.xml
xmlto man $<
endif
if XMLTOHTML
-html: gphoto2.xml
+htmldir=@HTML_DIR@
+
+TARGET_DIR=$(htmldir)/manual
+
+all-local: manual
+
+manual: gphoto2.xml
xmlto html -o $@ $<
touch $@
+
+install-data-local:
+ $(INSTALL) -d -m 0755 $(DESTDIR)$(TARGET_DIR)
+ $(INSTALL_DATA) ./manual/*.html $(DESTDIR)$(TARGET_DIR)
+
+dist-hook:
+ (cd $(srcdir) ; tar cvf - manual) | (cd $(distdir); tar xf -)
endif