summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2012-04-13 00:21:51 +0100
committerPhilip Withnall <philip@tecnocode.co.uk>2012-04-13 15:10:11 +0100
commitc8eca065e5f3f11d0ec8c7aac497e19f7d07469e (patch)
treed66b7e545ff299fd68fda0aa7e8a512d2464f79d /Makefile.am
parent5eea510bb492e62e76e515534f4f02be85caac81 (diff)
downloadlibgdata-c8eca065e5f3f11d0ec8c7aac497e19f7d07469e.tar.gz
documents: Split upload parameters out into GDataDocumentsUploadQuery
This new object currently only specifies the destination folder for an upload (replacing the folder argument to gdata_documents_service_upload_document_resumable()), but will in future allow specifying things like the ‘convert’ and OCR parameters for uploads. API additions: • GDataDocumentsUploadQuery and its methods API breaks: • gdata_documents_service_upload_document_resumable() (Note that this API hasn’t yet been in a libgdata release, so this isn’t a real API break.) Helps: https://bugzilla.gnome.org/show_bug.cgi?id=656971
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c6870ca..8a63c230 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -253,7 +253,8 @@ gdata_documents_headers = \
gdata/services/documents/gdata-documents-text.h \
gdata/services/documents/gdata-documents-presentation.h \
gdata/services/documents/gdata-documents-folder.h \
- gdata/services/documents/gdata-documents-spreadsheet.h
+ gdata/services/documents/gdata-documents-spreadsheet.h \
+ gdata/services/documents/gdata-documents-upload-query.h
gdatadocumentsinclude_HEADERS = \
$(gdata_documents_headers) \
gdata/services/documents/gdata-documents-enums.h
@@ -369,6 +370,7 @@ gdata_sources = \
gdata/services/documents/gdata-documents-spreadsheet.c \
gdata/services/documents/gdata-documents-folder.c \
gdata/services/documents/gdata-documents-query.c \
+ gdata/services/documents/gdata-documents-upload-query.c \
\
gdata/services/picasaweb/gdata-picasaweb-album.c \
gdata/services/picasaweb/gdata-picasaweb-query.c \