summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2010-04-23 14:13:09 +0100
committerPhilip Withnall <philip@tecnocode.co.uk>2010-04-23 14:13:09 +0100
commit4468035a9fab71253d66bf50234d9ca50cb3328a (patch)
tree982bfd12b396c49b93389599f2feda0aa1938f36 /Makefile.am
parentfd1ad35ae98f811a893392698a54f39a9b2ea268 (diff)
downloadlibgdata-4468035a9fab71253d66bf50234d9ca50cb3328a.tar.gz
Bug 616222 — libgdata fails to build from a remote directory
Be more strict in our use of top_[srcdir|builddir]. Closes: bgo#616222
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 13 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index e8479093..f62b093e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,11 +9,11 @@ GDATA_MARSHAL_FILES = \
gdata/gdata-marshal.h
gdata/gdata-marshal.h: $(top_srcdir)/gdata/gdata-marshal.list Makefile
- $(AM_V_GEN)($(GLIB_GENMARSHAL) --prefix=gdata_marshal $(srcdir)/gdata/gdata-marshal.list --header > $@)
-gdata/gdata-marshal.c: $(top_srcdir)/gdata/gdata-marshal.h Makefile
- $(AM_V_GEN)($(GLIB_GENMARSHAL) --prefix=gdata_marshal $(srcdir)/gdata/gdata-marshal.list --header --body > $@)
+ $(AM_V_GEN)($(GLIB_GENMARSHAL) --prefix=gdata_marshal $(top_srcdir)/gdata/gdata-marshal.list --header > $@)
+gdata/gdata-marshal.c: gdata/gdata-marshal.h Makefile
+ $(AM_V_GEN)($(GLIB_GENMARSHAL) --prefix=gdata_marshal $(top_srcdir)/gdata/gdata-marshal.list --header --body > $@)
-EXTRA_DIST = gdata/gdata-marshal.list
+EXTRA_DIST = $(top_srcdir)/gdata/gdata-marshal.list
CLEANFILES = $(GDATA_MARSHAL_FILES)
# Enums
@@ -352,14 +352,18 @@ gdata_libgdata_la_SOURCES = \
# All but the first two -I flags here are to cope with compiling the enum files in a srcdir!=builddir environment
gdata_libgdata_la_CPPFLAGS = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/gdata \
- -I$(top_srcdir)/gdata/media \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/gdata \
+ -I$(top_srcdir)/gdata/media \
-I$(top_srcdir)/gdata/services/documents \
-I$(top_srcdir)/gdata/services/picasaweb \
-I$(top_srcdir)/gdata/services/youtube \
- -DG_LOG_DOMAIN=\"libgdata\" \
- $(DISABLE_DEPRECATED) \
+ -I$(top_builddir)/gdata \
+ -I$(top_builddir)/gdata/media \
+ -I$(top_builddir)/gdata/services/picasaweb \
+ -I$(top_builddir)/gdata/services/youtube \
+ -DG_LOG_DOMAIN=\"libgdata\" \
+ $(DISABLE_DEPRECATED) \
$(AM_CPPFLAGS)
gdata_libgdata_la_CFLAGS = \