summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorbrane <brane@13f79535-47bb-0310-9956-ffa450edef68>2003-03-18 23:10:14 +0000
committerbrane <brane@13f79535-47bb-0310-9956-ffa450edef68>2003-03-18 23:10:14 +0000
commit9fbda5b61d60512d26277031fad04c082ef81f35 (patch)
tree349500e3192fae7d9469c241c75555d35c1ea2b1 /configure.in
parent4c361904eeaaaa378ec0ea37d92a11f480a3a9ac (diff)
downloadlibapr-9fbda5b61d60512d26277031fad04c082ef81f35.tar.gz
Define a printf format and format length for apr_uint64_t.
Also define APR_INT64_T_FMT_LEN on Windows and Netware; Unix already defines that symbol. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@64422 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 85074066f..50f74ecfb 100644
--- a/configure.in
+++ b/configure.in
@@ -1071,6 +1071,8 @@ if test "$ac_cv_sizeof_int" = "8"; then
int64_literal='#define APR_INT64_C(val) (val)'
int64_t_fmt='#define APR_INT64_T_FMT "d"'
int64_t_fmt_len='#define APR_INT64_T_FMT_LEN 1'
+ uint64_t_fmt='#define APR_UINT64_T_FMT "u"'
+ uint64_t_fmt_len='#define APR_UINT64_T_FMT_LEN 1'
int64_value="int"
long_value=int
int64_strfn="strtoi"
@@ -1078,6 +1080,8 @@ elif test "$ac_cv_sizeof_long" = "8"; then
int64_literal='#define APR_INT64_C(val) (val##L)'
int64_t_fmt='#define APR_INT64_T_FMT "ld"'
int64_t_fmt_len='#define APR_INT64_T_FMT_LEN 2'
+ uint64_t_fmt='#define APR_UINT64_T_FMT "lu"'
+ uint64_t_fmt_len='#define APR_UINT64_T_FMT_LEN 2'
int64_value="long"
long_value=long
int64_strfn="strtol"
@@ -1089,6 +1093,8 @@ elif test "$ac_cv_sizeof_long_long" = "8"; then
# go to the OS-dependent section.
int64_t_fmt='#define APR_INT64_T_FMT "lld"'
int64_t_fmt_len='#define APR_INT64_T_FMT_LEN 3'
+ uint64_t_fmt='#define APR_UINT64_T_FMT "llu"'
+ uint64_t_fmt_len='#define APR_UINT64_T_FMT_LEN 3'
int64_value="long long"
long_value="long long"
int64_strfn="strtoll"
@@ -1096,6 +1102,8 @@ elif test "$ac_cv_sizeof_long_double" = "8"; then
int64_literal='#define APR_INT64_C(val) (val##LD)'
int64_t_fmt='#define APR_INT64_T_FMT "Ld"'
int64_t_fmt_len='#define APR_INT64_T_FMT_LEN 2'
+ uint64_t_fmt='#define APR_UINT64_T_FMT "Lu"'
+ uint64_t_fmt_len='#define APR_UINT64_T_FMT_LEN 2'
int64_value="long double"
long_value="long double"
int64_strfn="strtoll"
@@ -1103,6 +1111,8 @@ elif test "$ac_cv_sizeof_longlong" = "8"; then
int64_literal='#define APR_INT64_C(val) (val##LL)'
int64_t_fmt='#define APR_INT64_T_FMT "qd"'
int64_t_fmt_len='#define APR_INT64_T_FMT_LEN 2'
+ uint64_t_fmt='#define APR_UINT64_T_FMT "qu"'
+ uint64_t_fmt_len='#define APR_UINT64_T_FMT_LEN 2'
int64_value="__int64"
long_value="__int64"
int64_strfn="strtoll"
@@ -1112,6 +1122,8 @@ else
int64_literal='#error Can not determine the proper size for apr_int64_t'
int64_t_fmt='#error Can not determine the proper size for apr_int64_t'
int64_t_fmt_len='#error Can not determine the proper size for apr_int64_t'
+ uint64_t_fmt='#error Can not determine the proper size for apr_int64_t'
+ uint64_t_fmt_len='#error Can not determine the proper size for apr_int64_t'
fi
# If present, allow the C99 macro INT64_C to override our conversion.
@@ -1250,6 +1262,8 @@ AC_SUBST(ssize_t_value)
AC_SUBST(socklen_t_value)
AC_SUBST(int64_t_fmt)
AC_SUBST(int64_t_fmt_len)
+AC_SUBST(uint64_t_fmt)
+AC_SUBST(uint64_t_fmt_len)
AC_SUBST(ssize_t_fmt)
AC_SUBST(size_t_fmt)
AC_SUBST(off_t_fmt)