summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Schuldt <michael.schuldt@bmw.de>2012-03-02 14:16:44 +0200
committerMichael Schuldt <michael.schuldt@bmw.de>2012-03-02 14:16:44 +0200
commit14b64a41ab77db82d546d97abdf39105a1b877c1 (patch)
tree9441e660b5dce5c5da5f483c52ab7b1fd311d7fc /CMakeLists.txt
parentc4f14d2c403acac6699607d9156440d083d927cd (diff)
downloadlayer_management-14b64a41ab77db82d546d97abdf39105a1b877c1.tar.gz
LayerManagerService: Moving config file to new location
- The config file should be available at all sub modules - Therefore it was moved to an own directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b42ba3..4c9e0bb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,6 +49,14 @@ option (WITH_DLT "Build with DLT support "
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra")
+# generate cmake configuration header file, includes information on the
+# project configuration, compiler settings, ...
+message(STATUS "Generating config.h header file with build system configuration.")
+configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/config/config.h.cmake
+ ${CMAKE_CURRENT_SOURCE_DIR}/config/config.h
+)
+
if (WITH_DESKTOP)
set (WITH_GLX_LIB ON CACHE STRING "" FORCE)
endif(WITH_DESKTOP)
@@ -62,9 +70,9 @@ include_directories ("${PROJECT_SOURCE_DIR}/3rdParty/")
add_subdirectory (3rdParty)
add_subdirectory (LayerManagerPlugins/Communicators/DBUSCommunicator)
add_subdirectory (LayerManagerClient/ilmClient)
-add_subdirectory (LayerManagerUtils)
add_subdirectory (LayerManagerCommands)
add_subdirectory (LayerManagerService)
+add_subdirectory (LayerManagerUtils)
if (WITH_GLESv2_LIB OR WITH_GLX_LIB)
add_subdirectory (LayerManagerPlugins/Renderers/Graphic)